If attachment creation for new report fails due to filesize, error message does not tell reason

RESOLVED DUPLICATE of bug 365827

Status

()

Bugzilla
Attachments & Requests
RESOLVED DUPLICATE of bug 365827
6 years ago
5 years ago

People

(Reporter: Andre Klapper, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
Upstreaming from https://bugs.merproject.org/show_bug.cgi?id=473

This is about inconsistencies in error messages thrown.
Bugzilla 3.6.2.0-4.5 but still reproducible with https://landfill.bugzilla.org/bugzilla-4.2-branch/enter_bug.cgi


STEPS:
1.  Under "Administration", "maxattachmentsize" is set to "1000" (kb).
2a. File a *new* ticket (enter_bug.cgi) and attach a big file initially
    ("patch" checkbox IS checked).
3a. Result is vague:
    "The bug was created successfully, but attachment creation failed. 
    Please add your attachment by clicking the "Add an Attachment" link below."

2b. File a *new* ticket (enter_bug.cgi) and attach a big file initially
    ("patch" checkbox NOT checked).
3b. Result is vague:
    "The bug was created successfully, but attachment creation failed. 
    Please add your attachment by clicking the "Add an Attachment" link below. "

2c. In an *existing* ticket (show_bug.cgi), attach a big file 
    ("patch" checkbox NOT checked) to an *existing* ticket.
3c. Result is helpful:
    "The file you are trying to attach is xxxxx kilobytes (KB) in size. 
    Non-patch attachments cannot be more than 1000 KB.
    We recommend that you store your attachment elsewhere and then insert the URL 
    to it in a comment, or in the URL field for this bug.
    Alternately, if your attachment is an image, you could convert it to a 
    compressible format like JPG or PNG and try again."

2d. In an *existing* ticket (show_bug.cgi), attach a big file
    ("patch" checkbox IS checked) to an *existing* ticket.
3d. Result is helpful:
    "The file you are trying to attach is xxxxx kilobytes (KB) in size. 
    Patches cannot be more than 1000 KB in size. Try splitting your patch into 
    several pieces."


EXPECTED OUTCOME for a and b:
A similar message like in c and d.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 365827
You need to log in before you can comment on or make changes to this bug.