The default bug view has changed. See this FAQ.

Make twitter account setup less fragile

RESOLVED FIXED in Thunderbird 17.0

Status

Thunderbird
Instant Messaging
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: thomas, Assigned: florian)

Tracking

15 Branch
Thunderbird 17.0
x86
All

Thunderbird Tracking Flags

(thunderbird15 fixed, thunderbird16 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713224758

Steps to reproduce:

I tried to add more than one Twitter Account, but login was not possible for the second account.


Actual results:

I can only use one Twitter Account in the new Chat Tab. After authentication via Twitter API I get the following error:

"Error: Username mismatch" 


Expected results:

It would be nice, if I could use multiple Twitter Accounts

Comment 1

5 years ago
Were you able to create those 2 accounts in the account manager? If yes, then one of the accounts did not work?
Component: Account Manager → Instant Messaging
(Reporter)

Comment 2

5 years ago
Ok, know it works for me too.. the problem was, that TB is case-sensitive and throws the error "User mismatch", if the username is not correct. Twitter is not as restrict here (not case-sensitive!), so maybe it would be better to change this in TB as well.
(Assignee)

Comment 3

5 years ago
Created attachment 644958 [details] [diff] [review]
Patch

Changes included in this patch:
- fix the case in account names instead of refusing to connect the account (fixes what's described in comment 2)
- ignore existing cookies when opening the authorization dialog. I suspect this fixes what was initially described in comment 0.
- prefill the input box in the authorization dialog.
Assignee: nobody → florian
Attachment #644958 - Flags: review?(clokep)
(Assignee)

Updated

5 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Summary: Multiple Twitter Accounts not working → Make twitter account setup less fragile
Comment on attachment 644958 [details] [diff] [review]
Patch

This looks good! :) Thanks for fixing these annoyances.
Attachment #644958 - Flags: review?(clokep) → review+
(Assignee)

Updated

5 years ago
Attachment #644958 - Flags: approval-comm-beta?
Attachment #644958 - Flags: approval-comm-aurora?
Attachment #644958 - Flags: approval-comm-beta?
Attachment #644958 - Flags: approval-comm-beta+
Attachment #644958 - Flags: approval-comm-aurora?
Attachment #644958 - Flags: approval-comm-aurora+
comm-central: https://hg.mozilla.org/comm-central/rev/62a941631475
comm-aurora: https://hg.mozilla.org/releases/comm-aurora/rev/3c7e60ef4858
comm-beta: https://hg.mozilla.org/releases/comm-beta/rev/4c63a7a39781
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
status-thunderbird15: --- → fixed
status-thunderbird16: --- → fixed
OS: Linux → All
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 17.0
Backed out of comm-beta since we landed on a SeaMonkey relbranch (oops).

Re-landed on comm-beta as: https://hg.mozilla.org/releases/comm-beta/rev/7ebadaff038e
You need to log in before you can comment on or make changes to this bug.