Intermittent DOMCore/tests/approved/test_Range-insertNode.html | 15,16: resulting DOM for range [document.documentElement, 0, document.documentElement, 1], node xmlDoc; Exception seems to not be a DOMException? [Exception... "Node cannot be inserted...

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: emorley, Unassigned)

Tracking

({intermittent-failure})

Trunk
x86
Linux
intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Rev3 Fedora 12 mozilla-inbound pgo test mochitests-2/5 on 2012-07-22 19:09:25 PDT for push c07793b7dc10

slave: talos-r3-fed-070

https://tbpl.mozilla.org/php/getParsedLog.php?id=13761417&tree=Mozilla-Inbound

{
6491 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/imptests/webapps/DOMCore/tests/approved/test_Range-insertNode.html | 15,16: resulting DOM for range [document.documentElement, 0, document.documentElement, 1], node xmlDoc; Exception seems to not be a DOMException?  [Exception... "Node cannot be inserted at the specified point in the hierarchy"  code: "3" nsresult: "0x80530003 (HierarchyRequestError)"  location: "http://mochi.test:8888/tests/dom/imptests/webapps/DOMCore/tests/approved/common.js Line: 883"]
...
...
2 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/indexedDB/test/test_transaction_lifetimes.html | request.transaction should still be set - got null, expected [object IDBTransaction]
}
My best bet is PGO miscompiling something.
Or racy test? The test has all sorts of load event listeners
Well, 2 at least :)
The failure in test_Range-insertNode.html is caused by getDomExceptionName throwing an exception, here:

https://hg.mozilla.org/mozilla-central/file/82b6c5885345/dom/imptests/webapps/DOMCore/tests/approved/common.js#l918

The complete function is:

/**
 * Given a DOMException, return the name (e.g., "HIERARCHY_REQUEST_ERR").
 */
function getDomExceptionName(e) {
	var ret = null;
	for (var prop in e) {
		if (/^[A-Z_]+_ERR$/.test(prop) && e[prop] == e.code) {
			return prop;
		}
	}

	throw "Exception seems to not be a DOMException?  " + e;
}

The throw line is actually being hit.  That is not even slightly sane -- it means the HierarchyRequestError object doesn't have the proper HIERARCHY_REQUEST_ERR member.  It can't be just a race condition.  I agree with Ms2ger that it's more likely to be a compiler bug than anything.

Let's see if it reoccurs.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Updated

6 years ago
Keywords: intermittent-failure
(Assignee)

Updated

6 years ago
Whiteboard: [orange]
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 10

6 years ago
Resolving WFM keyword:intermittent-failure bugs last modified >3 months ago, whose whiteboard contains none of:
{random,disabled,marked,fuzzy,todo,fails,failing,annotated,time-bomb,leave open}

There will inevitably be some false positives; for that (and the bugspam) I apologise. Filter on orangewfm.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.