Assert permissions for WebTelephony and MobileConnection access

RESOLVED FIXED in mozilla18

Status

()

defect
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: cjones, Assigned: philikon)

Tracking

Trunk
mozilla18
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Whiteboard: [WebAPI:P1][LOE:S])

Attachments

(1 attachment, 1 obsolete attachment)

No description provided.
blocking-basecamp: --- → +
Chris - Can you give more context on what this bug is and help us find an assignee?
Arbitrary content processes shouldn't be able to talk to the modem, only those with telephony privileges.
Assignee: nobody → philipp
Whiteboard: [WebAPI:P1]
Keywords: feature
Depends on: 776832
Whiteboard: [WebAPI:P1] → [WebAPI:P1][LOE:S]
Summary: Check capabilities for telephony access → Check capabilities for WebTelephony and MobileConnection access
Duplicate of this bug: 783623
Posted patch v1 (obsolete) — Splinter Review
Attachment #663254 - Flags: review?(marshall)
Posted patch v1.1Splinter Review
Rebased after bug 776832 changed the API slightly.
Attachment #663254 - Attachment is obsolete: true
Attachment #663254 - Flags: review?(marshall)
Attachment #663609 - Flags: review?(marshall)
Summary: Check capabilities for WebTelephony and MobileConnection access → Assert permissions for WebTelephony and MobileConnection access
Comment on attachment 663609 [details] [diff] [review]
v1.1

Nice.
Attachment #663609 - Flags: review?(marshall) → review+
(In reply to Chris Jones [:cjones] [:warhammer] from comment #6)
> Nice.

Thanks! I'll land as soon as I can be sure bug 776832 sticks.
This should probably never have had the feature keyword.  Sorry for the noise.
Keywords: feature
The three changesets in the push backed out for causing (/conflicting with the backout of):
https://tbpl.mozilla.org/php/getParsedLog.php?id=15626544&tree=Mozilla-Inbound

Backout:
https://hg.mozilla.org/integration/mozilla-inbound/rev/dc9d251fdb2e
https://hg.mozilla.org/mozilla-central/rev/5caa455ee564
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla18
You need to log in before you can comment on or make changes to this bug.