Last Comment Bug 776836 - some garbage drawn when zooming in
: some garbage drawn when zooming in
Status: RESOLVED FIXED
: regression, testcase
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla17
Assigned To: Robert O'Callahan (:roc) (email my personal email if necessary)
: Simona B [:simonab ] -PTO- back Sept 5th
Mentors:
https://bug775562.bugzilla.mozilla.or...
: 778701 (view as bug list)
Depends on:
Blocks: 773100
  Show dependency treegraph
 
Reported: 2012-07-24 00:11 PDT by Timothy Nikkel (:tnikkel)
Modified: 2014-01-10 10:42 PST (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
verified
+
verified


Attachments
single green div testcase (212 bytes, text/html)
2012-08-01 20:10 PDT, Karl Tomlinson (:karlt)
no flags Details
fix (5.06 KB, patch)
2012-08-05 17:47 PDT, Robert O'Callahan (:roc) (email my personal email if necessary)
matt.woodrow: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Timothy Nikkel (:tnikkel) 2012-07-24 00:11:36 PDT
Load https://bug775562.bugzilla.mozilla.org/attachment.cgi?id=643857 and zoom in/out a few times. I get some garbage drawn at the top at some zooms.

Verified that it is caused by bug 773100.
Comment 1 (mostly gone) XtC4UaLL [:xtc4uall] 2012-07-28 16:47:27 PDT
I can confirm this against Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120728030524 with HWA off only.
Comment 2 Karl Tomlinson (:karlt) 2012-08-01 20:10:40 PDT
Created attachment 648200 [details]
single green div testcase

Most obvious when zooming out then in.
Also visible when zooming in a couple of times.
Comment 3 Karl Tomlinson (:karlt) 2012-08-01 20:13:58 PDT
8a9f2d2b75d4 was also transplanted to aurora so I assume we need to track this on 16 also.
Comment 4 Karl Tomlinson (:karlt) 2012-08-01 20:18:38 PDT
There are
"###!!! ASSERTION: bad aListVisibleBounds: 'r.GetBounds().IsEqualInterior(aListVisibleBounds)', file [...]/layout/base/nsDisplayList.cpp, line 487"
failures with and without 8a9f2d2b75d4.
Comment 5 Lukas Blakk [:lsblakk] use ?needinfo 2012-08-03 12:21:28 PDT
Lawrence mentioned in triage that tabbing away and tabbing back restores the expected appearance so we might have a work around to provide if the fix for this isn't available quickly.
Comment 6 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-08-05 17:47:22 PDT
Created attachment 649158 [details] [diff] [review]
fix

I haven't found a good way to test this.
Comment 7 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-08-07 04:08:44 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/e52c71762ca4
Comment 8 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-08-07 14:46:03 PDT
Comment on attachment 649158 [details] [diff] [review]
fix

Review of attachment 649158 [details] [diff] [review]:
-----------------------------------------------------------------

Very low risk. We just invalidate more aggressively when zooming. Fixes a pretty bad rendering regression when zooming.
Comment 9 Ed Morley [:emorley] 2012-08-08 09:36:25 PDT
https://hg.mozilla.org/mozilla-central/rev/e52c71762ca4
Comment 10 Karl Tomlinson (:karlt) 2012-08-09 19:51:23 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/56e05fc79712
Comment 11 Alice0775 White 2012-08-24 18:33:08 PDT
*** Bug 778701 has been marked as a duplicate of this bug. ***
Comment 12 Simona B [:simonab ] -PTO- back Sept 5th 2012-09-21 04:30:19 PDT
Verified that zooming in and zooming out works properly (without any rendering issues) on Firefox 16 beta 4 - on Windows 7, Ubuntu 12.04 and Mac OS X 10.7.
Verified with hardware acceleration enabled/disabled using the test cases provided in this bug (in the Description and in Comment 2) and in Bug 778701. 

Mozilla/5.0 (Windows NT 6.1; rv:16.0) Gecko/20100101 Firefox/16.0
Mozilla/5.0 (X11; Linux i686; rv:16.0) Gecko/20100101 Firefox/16.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:16.0) Gecko/20100101 Firefox/16.0
Comment 13 Simona B [:simonab ] -PTO- back Sept 5th 2012-10-16 08:33:33 PDT
Verified as fixed on Firefox 17 beta 1 - zooming in and out works properly (without any rendering issues) on Windows 7, Ubuntu 12.04 and Mac OS X 10.7.

Mozilla/5.0 (Windows NT 6.1; rv:17.0) Gecko/17.0 Firefox/17.0
Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/17.0 Firefox/17.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:17.0) Gecko/17.0 Firefox/17.0
Comment 14 Tracy Walker [:tracy] 2014-01-10 10:42:38 PST
mass remove verifyme requests greater than 4 months old

Note You need to log in before you can comment on or make changes to this bug.