If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

pale greys have a pink tint

RESOLVED FIXED

Status

()

Firefox for Android
Graphics, Panning and Zooming
RESOLVED FIXED
5 years ago
a year ago

People

(Reporter: david.scotson, Unassigned)

Tracking

15 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:14.0) Gecko/20100101 Firefox/14.0
Build ID: 20120629174931

Steps to reproduce:

Visited http://twitter.github.com/bootstrap/base-css.html#tables

I was looking at the tables which I knew have a striped background of #f9f9f9 gray because I'm currently using the same CSS elsewhere.


Actual results:

The tables have a striped background of #f9f9f9 gray yet they appear pale pink on my Samsung Galaxy Note (N7000).


Expected results:

I assumed at first that the tinge was due to the AMOLED display which is supposed to have color fidelity issues, however when viewing the page in Android Chrome, Android Browser or Opera Mobile the gray stripes are gray.

(Two things to note: one the built in browser, Android Browser originally had a blue tinge, but this was due to it being in a powersaving mode, when I turned it off it matched the other two browsers. Second, some of the pale gray backgrounds on the same page have a slight amount of extra blue compared with red and green, but the table background should be equally gray according to the CSS.

Updated

5 years ago
OS: Linux → Android
Hardware: x86 → ARM
Does this look different in Nightly? builds at http://nightly.mozilla.org we have a fix for bug 683243 in those builds.
(Reporter)

Comment 2

5 years ago
No different on nightly 17.0a1 (2012-08-01).

I no longer have the Galaxy Note, but I tested the latest beta and nightly on both a Galaxy Nexus and a Nexus 7 tablet. The former has an AMOLED screen like the Note and the latter has a more traditional LCD. The bug is still present in both, though it's harder to see in the non-AMOLED screen as the pink is whiter. You can still notice it if you switch between two different browsers.
Core::Graphics?
Adding a bunch of gfx people.
This is caused by us using 16 bit color. #f9f9f9 gets rounded to #fffbff which has less green than red and blue.
Depends on: 764041

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
This should be fixed as of bug 803299. Please reopen if it is still an issue.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Depends on: 803299
No longer depends on: 764041
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.