Closed Bug 777352 Opened 8 years ago Closed 6 years ago

"add library in Add-on Editor" could not find my own public library

Categories

(addons.mozilla.org Graveyard :: Add-on Builder, defect, P1, critical)

defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: backy0175, Assigned: aschaar)

References

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713134347

Steps to reproduce:

I try to add(incorporate) my own public library into my addon.


Actual results:

Add library in addon editor could not find my own public library.


Expected results:

Add library in editor must be find my own public library.
Severity: normal → critical
Priority: -- → P1
I wasn't able to reproduce this.  I created a new library and a new addon and was able to add the library to the addon after a few minutes.   I just want note that it takes a few minutes for new libraries and addons to be included in search.  Also make sure that you update the libraries version to something other than 'initial'.  We filter those out by default.
I created new library and new addon both in public.
Changed library version from 'initial' to '1.0'
Waited over 10 minutes.

But still addon editor could not find my own public library.

I tested 2 other PCs which worked Add-on Builder perfectly before.
But these PCs also have same problem.

Can you give me any way to figure it out?
In my quick hack.

Library search api returns null array.

https://builder.addons.mozilla.org/autocomplete/library/?q=backy&limit=20

Name of my own test public library include keyword 'backy'.
So, I think, search api or backend database have problem.
Do your libraries show up in the public search?   For example, here's my library that I created while I was investigating this ticket.  https://builder.addons.mozilla.org/search/?q=arron
Attached image Screenshot of Dashboard
(In reply to Arron Schaar [:arron] from comment #4)
> Do your libraries show up in the public search?

No. public search said:

Library Results (0)
No results were found for the term "backy".
I tested this problem in new account.
and got same result, addon editor could not find my own public library.

reproduce steps as follows:

1. create new account
2. login addon builder
3. create new public library
   add some code and change version and save
4. create new public addon
5. try to add my own public library
   but addon editor could not find my public library
6. add some code and change version and save public addon
7. try 'addon builder narrow search'
   https://builder.addons.mozilla.org/search/?type=a
   https://builder.addons.mozilla.org/search/?type=l
   but I got 'no results' in search addon and search library
Thanks backy for all the info.  I just tried to create a new library and this time it's not working.  I'm going to try to reproduce this locally and get back to you.
Assignee: nobody → aschaar
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Thanks arron,

It is the real trouble shoot from here. ;-)

and I think Bug No. 766809 is possibly also related.
https://bugzilla.mozilla.org/show_bug.cgi?id=766809
Backy, What version label did you give your library?
(In reply to Arron Schaar [:arron] from comment #9)
> Backy, What version label did you give your library?

my original account:
  public library version is 1.0

my test account:
 public library version is 0.1
 public addon versoin is 0.1
Can you try incrementing your library version and saving it again. It should show up in search and the auto-completer after that.  

I just created a patch that will go out in our next release that will fix this issue.
Attached image still not found
(In reply to Arron Schaar [:arron] from comment #11)
> Can you try incrementing your library version and saving it again. It should
> show up in search and the auto-completer after that.  

I tried your request, but still 'not found' occurred.
Hi, arron.

It seems "search public addon and library" is working, now.
Did you fix it?
Could you tell me what went wrong?
Is it resolved then?
(In reply to Piotr Zalewa [:zalun] from comment #14)
> Is it resolved then?

I'm not sure.

It seems "search public addon and library" is working.

Arron said "will go out in our next release that will fix this issue".
But, I couldn't confirm version number and release date of addon builder.
Is there any indication of version number and release date?
Yes, I created a patch that fixes this issue, however I'm not sure if the code is on live yet.  I confirmed that it works on dev.
(In reply to Arron Schaar [:arron] from comment #16)
> Yes, I created a patch that fixes this issue

I found a patch that you created.
https://github.com/pennyfx/FlightDeck/commit/ae7a26eadada6baee2b83747c8cca4052643ccde


> however I'm not sure if the code is on live yet.

How do I know when code is on live?
I'm still seeing this problem today, discussed with Arron in IRC and still looking for a solution. Feels like something is 'stuck'?
Seems to not working again for new library(both public and private).
What is going on?

backy0175
I posted Bug 792332 "addon builder - weird search results" today.
I believe this bug and Bug 792332 have relations.

backy0175
Duplicate of this bug: 766809
Hi, All.
Add library doesn't work for new library(both public and private) again.
Please fix this problem completely.

backy0175
The builder project has been discontinued as of April 1st, 2014.

The announcement last year: https://blog.mozilla.org/addons/2013/12/18/add-on-builder/

Next steps (still being written): https://developer.mozilla.org/en-US/Add-ons/SDK/Builder
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.