Modal dialog used for pointless "operation failed" message

RESOLVED DUPLICATE of bug 288896

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 288896
6 years ago
5 years ago

People

(Reporter: gessel@blackrosetech.com, Unassigned)

Tracking

14 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme])

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713134347

Steps to reproduce:

Fairly reliably when synchronizing folders ("work offline" or "download/sync now")...


Actual results:

...just about every folder reports via an incredibly irritating and useless modal dialog "Alert: The operation failed because another operation is using the folder. Please wait for that operation to finish and then try again."


Expected results:

There is never an excuse for a modal dialog.  Ever.  Particularly one that stops background processes.  Especially one that steals focus from whatever else I'm doing, like composing a message.  A summary, non-modal dialog may be useful if I'm performing a disconnect operation along the lines of "the following mailboxes were not synced because another operation was using them."  That alert might be justified as I may be disconnecting and might want to know whether I got all my mail off my IMAP server and onto my local device for use while disconnected.

If I'm not disconnecting then there's no earthly reason why a normal user would care whether another operation was using the folder; Thunderbird should silently, obediently retry the sync operation later.  I'm not debugging the sync process, I just want my mail.  There's nothing I can do about the "other operation using the folder" but be annoyed and try again later - so why not simply do that for me silently in the background and avoid the annoyance.

Comment 1

5 years ago
is this not a duplicate?
https://bugzilla.mozilla.org/buglist.cgi?query_format=advanced;short_desc_type=allwordssubstr;resolution=---;type0-0-0=nowords;value0-0-0=count%20counts;product=MailNews%20Core;product=Thunderbird;short_desc=modal;list_id=4364826
Whiteboard: [dupeme]
(Reporter)

Comment 2

5 years ago
Yep - it is a duplicate of bug 288896 that was first reported in 2005 and still hasn't been fixed.  The OP of that bug is absolutely correct - these modal dialogs have to go!  It is kind of amazing that such a basic UI failure has persisted for so many years (at least 7!).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 288896
You need to log in before you can comment on or make changes to this bug.