Last Comment Bug 777746 - Remove Tegra blacklist for Flash
: Remove Tegra blacklist for Flash
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: Plugins (show other bugs)
: unspecified
: ARM Android
: -- normal (vote)
: Firefox 17
Assigned To: James Willcox (:snorp) (jwillcox@mozilla.com)
:
Mentors:
Depends on: 703056
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-26 08:55 PDT by James Willcox (:snorp) (jwillcox@mozilla.com)
Modified: 2012-08-31 08:18 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
verified
+
verified
verified


Attachments
Don't block Flash for Tegra on Gingerbread/Froyo (1.77 KB, patch)
2012-07-26 09:05 PDT, James Willcox (:snorp) (jwillcox@mozilla.com)
blassey.bugs: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
lukasblakk+bugs: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description James Willcox (:snorp) (jwillcox@mozilla.com) 2012-07-26 08:55:14 PDT
On latest code this actually works (albeit a little buggy), so we should remove the blacklist.
Comment 1 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-07-26 09:04:35 PDT
I should clarify, we're only talking about Gingerbread/Froyo here.
Comment 2 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-07-26 09:05:10 PDT
Created attachment 646164 [details] [diff] [review]
Don't block Flash for Tegra on Gingerbread/Froyo
Comment 3 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-07-26 12:42:26 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/1b04613c43c9
Comment 5 Tony Chung [:tchung] 2012-07-27 15:16:17 PDT
qawanted: take a look at tegra 2 (froyo or GB) devices and verify if flash is working.  

private build: http://dump.lassey.us/fennec-15.0.en-US.android-arm.apk
Comment 6 Cristian Nicolae (:xti) 2012-07-30 08:22:48 PDT
The Flash was enabled on Tegra2 FroYo devices. However the performance is really poor, there are layouts issues when zooming, panning or rotating the device. Sometimes the OS freezes or even a restart may occur. More details can be found here: https://etherpad.mozilla.org/tegra2-flash

--
Device: LG Optimus 2X
OS: Android 2.2
Comment 7 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-08-01 09:35:49 PDT
(In reply to Cristian Nicolae (:xti) from comment #6)
> The Flash was enabled on Tegra2 FroYo devices. However the performance is
> really poor, there are layouts issues when zooming, panning or rotating the
> device. Sometimes the OS freezes or even a restart may occur. More details
> can be found here: https://etherpad.mozilla.org/tegra2-flash
> 
> --
> Device: LG Optimus 2X
> OS: Android 2.2

Can you guys compare the experience in Firefox to stock browser? In my testing locally there are a lot of issues with stock as well.
Comment 8 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-08-07 12:56:00 PDT
Comment on attachment 646164 [details] [diff] [review]
Don't block Flash for Tegra on Gingerbread/Froyo

[Approval Request Comment]
Low risk, but will need some testing most likely especially for Beta
Comment 9 Lukas Blakk [:lsblakk] use ?needinfo 2012-08-09 10:11:10 PDT
Comment on attachment 646164 [details] [diff] [review]
Don't block Flash for Tegra on Gingerbread/Froyo

Approving, let's get this landed and verified.
Comment 10 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-08-10 12:36:10 PDT
https://hg.mozilla.org/releases/mozilla-beta/rev/375f160230b3
Comment 11 Lukas Blakk [:lsblakk] use ?needinfo 2012-08-15 09:44:35 PDT
resetting the flags, looks like an accidental wipe of tracking flags.
Comment 12 Adrian Tamas (:AdrianT) 2012-08-17 05:21:05 PDT
Flash plugin is enabled on Samsung Galaxy R running Android 2.3.4 for Firefox Mobile 15 beta 5 but the flash performance is very bad and resizes cause artifacts and have considerable lag.
Comment 13 Lukas Blakk [:lsblakk] use ?needinfo 2012-08-20 19:29:40 PDT
This still needs landing on Aurora (16)
Comment 14 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-08-22 09:32:55 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/5d7b893f5868

Note You need to log in before you can comment on or make changes to this bug.