Disable Flash on Tegra2 devices running Gingerbread because it doesn't paint

VERIFIED FIXED in Firefox 14

Status

()

Firefox for Android
General
P2
normal
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: snorp, Assigned: snorp)

Tracking

({relnote})

unspecified
Firefox 15
ARM
Android
relnote
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox14 verified, blocking-fennec1.0 +, fennec11+)

Details

(Whiteboard: sumo)

Attachments

(1 attachment, 1 obsolete attachment)

On Tegra 2 devices running Gingerbread, Flash wants to paint to the SurfaceView using OpenGL (according to logs). This doesn't seem to work on birch, and the current theory is that you can't have a GLSurfaceView (our gecko rendering stuff) under what is effectively another GLSurfaceView (the plugin). It's unclear if there will be a reasonable way to solve this. I think ideally we'd have a way to force Flash into the conventional paint mode.

Updated

6 years ago
Assignee: nobody → snorp
tracking-fennec: --- → 11+
Keywords: fennecnative-releaseblocker
It would be wonderful to fix this, but when we're getting closer to release, we need to have some contingency plan. I propose that that plan is to disable flash entirely on tegra2 running gingerbread.
I agree, we should just disable it.
blocking-fennec1.0: --- → +
Status: NEW → ASSIGNED
Summary: Flash doesn't paint on Tegra2 devices running Gingerbread → Disable Flash on Tegra2 devices running Gingerbread because it doesn't paint

Comment 3

5 years ago
Snorp, if you still agree with comment #2, lets just do it and relnote it.  Adding Jay to loop in product.  Should affect about 10% of phones in market.
Keywords: relnote
Whiteboard: sumo
Confirmed this with yesterday's m-c trunk on my Atrix running Gingerbread; flash doesn't paint correctly at all (a few gray squares on a youtube window, but that's it).

Updated

5 years ago
Blocks: 750968
Created attachment 620836 [details] [diff] [review]
Block Flash on Tegra devices
Attachment #620836 - Flags: review?(blassey.bugs)
Comment on attachment 620836 [details] [diff] [review]
Block Flash on Tegra devices

Review of attachment 620836 [details] [diff] [review]:
-----------------------------------------------------------------

::: mobile/android/base/GeckoApp.java
@@ +213,5 @@
>      String[] getPluginDirectories() {
> +
> +        // An awful hack to detect Tegra devices. Easiest way to do it without spinning up a EGL context
> +        File tegraDriverPath = new File("/system/lib/hw/gralloc.tegra.so");
> +        if (tegraDriverPath.exists())

check for gingerbread
Attachment #620836 - Flags: review?(blassey.bugs) → review+
Created attachment 620847 [details] [diff] [review]
Block Flash on Tegra devices
Attachment #620836 - Attachment is obsolete: true
Attachment #620847 - Flags: review+
Comment on attachment 620847 [details] [diff] [review]
Block Flash on Tegra devices

[Approval Request Comment]
Trivial patch, fixes very noticeable bug on a relatively popular set of devices. Mobile only.
Attachment #620847 - Flags: approval-mozilla-aurora?

Comment 9

5 years ago
https://hg.mozilla.org/mozilla-central/rev/086e419f370a
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 15
Attachment #620847 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/609e87ff8279
status-firefox14: --- → fixed
Verified fixed on Nightly 15.0a1 (2012-05-22)
                  Aurora 14.0a2 (2012-05-22)

Tegra device: LG Optimus 2X (2.2.2)
Status: RESOLVED → VERIFIED
status-firefox14: fixed → verified
Blocks: 736421
Blocks: 777746
You need to log in before you can comment on or make changes to this bug.