Closed Bug 778067 Opened 7 years ago Closed 7 years ago

Re-enable layout/base/crashtests/735943.html when we can support crashed content processes better

Categories

(Core :: DOM: Core & HTML, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: cjones, Unassigned)

References

Details

Attachments

(1 file)

See the comment in the upcoming patch.  Attempting to "fix" this is not a good use of resources at the moment, and may lead to other bugs.

The behavior triggered by bug 671196 is good: the parent process gets into a state it can't handle and kills the child process.  The problem is, the reftest harness doesn't know how to restart crashed content processes.  We need that, but bug 671196 is more important right now IMHO.
See comments in patch.  We should ensure that the mozbrowser window.open setup can handle this edge case.

This also raises the question of how to integrate <iframe mozbrowser> into the reftest harness, which you may want to participate in.  (Swapping it out for <browser remote> should be trivial.)
Assignee: nobody → jones.chris.g
Attachment #646491 - Flags: review?(justin.lebar+bug)
Comment on attachment 646491 [details] [diff] [review]
Disable 735943.html for <browser remote>, for now

sgtm
Attachment #646491 - Flags: review?(justin.lebar+bug) → review+
https://hg.mozilla.org/mozilla-central/rev/1b8130ed506c
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla17
Assignee: cjones.bugs → nobody
Flags: in-testsuite+
Resolution: FIXED → WORKSFORME
Target Milestone: mozilla17 → ---
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.