Reader: Toolbar breaks on device rotation

VERIFIED FIXED

Status

()

Firefox for Android
Reader View
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: aaronmt, Assigned: aaronmt)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox16 affected, firefox17 affected, firefox21 verified, fennec+)

Details

Attachments

(2 attachments)

(Assignee)

Description

5 years ago
Created attachment 646586 [details]
Nightly (07/27) - Screenshot

See screenshot. Upon device rotation (while the toolbar is open), the options menu automatically opens and and the to toolbar positioning is off.

I don't recall this happening prior, so I think this is a new regression.

--
Nightly (07/27)
Galaxy Nexus (Android 4.1.1)
(Assignee)

Updated

5 years ago
Duplicate of this bug: 779108
Positioning off is a bug that happened a while ago I thought... 

Isn't this a dup of bug 768043
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 768043
Keywords: regressionwindow-wanted
Actually found it's not a dup... reader bar is different.  It however does work for me in Aug 6th build.  Nightly
Resolution: DUPLICATE → WORKSFORME
Doh.  Spoke too soon.  

1. go to www.newyorktimes.com
2. click on an article in landscape mode
3. select reader mode
4. select reader menu
5. change the background from light to dark
6. switch to portrait mode
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Note: you may have to scroll on the reader mode before tapping on the content then tapping on the reader menu (between 3/4)

does not occur on 6/26/2012 build
occurs on 06/27/2012 Nightly build (16.0a1)

Note: scroll all the way down to the bottom on the 6/27/2012 build and then tap to bring the reader menu and you can see a black box overlaying on top of the content.
Keywords: regressionwindow-wanted

Comment 6

5 years ago
I think this is fixed in Nightly, or at least, I can't reproduce this in my local build (so I guess it could be fixed by bug 777260) - Perhaps it was fixed by bug 779269?
(Assignee)

Comment 7

5 years ago
I haven't seen this since filing.

Naoki reopen if still can.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → WORKSFORME

Comment 8

5 years ago
Since this is not reproducible anymore I'm removing the regressionwindow-wanted keyword.
Keywords: regressionwindow-wanted
Created attachment 670213 [details]
screenshot

Can repro in 16.0.1

1. open a news article in reader mode (www.nytimes.com article) in portrait
2. scroll til the reader mode menu fades
3. switch to landscape
4. double tap to bring back the menu 
5. switch to portrait with the menu still up.

expected: menu at the bottom
actual: menu at mid way.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
status-firefox16: --- → affected
Keywords: regressionwindow-wanted
tracking-fennec: ? → +

Comment 10

5 years ago
Using the STR form comment9 I can't reproduce this issue on latest Nyghtly 19.0a1 (2012-10-14), Aurora  18.0a2 (2012-10-14) and Firefox beta 17 using Galaxy Nexus (Android 4.1.1) HTC Desire Z (Android 2.3.3) and Samsung Galaxy R (Android 2.3.4)
(Assignee)

Updated

5 years ago
Assignee: nobody → aaron.train
(Assignee)

Comment 11

5 years ago
QA Triage Comment:

Tried this out on Firefox Beta 17.0

Re: steps in comment #9, what I see happen is that the menu appears dislodged from the bottom, but then swiftly snaps to the bottom fairly quickly. There is no permanent 'stuck' state for the toolbar in the middle of the viewable page.

Going to resolve this as the original problem is fixed and I can't reproduce otherwise.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Keywords: regression, regressionwindow-wanted
Resolution: --- → FIXED
This issue doesn't occur anymore on the latest Nightly. Closing bug as verified fixed on:

Firefox for Android
Version: 21.0a1 (2013-01-29)
Device: Galaxy R
OS: Android 2.3.4
Status: RESOLVED → VERIFIED
status-firefox21: --- → verified
You need to log in before you can comment on or make changes to this bug.