Last Comment Bug 778180 - Intermittent indexedDB/test/test_transaction_lifetimes.html | request.transaction should still be set - got null, expected [object IDBTransaction @ 0x263cd70 (native @ 0x2e77090)]
: Intermittent indexedDB/test/test_transaction_lifetimes.html | request.transac...
Status: RESOLVED FIXED
: intermittent-failure
Product: Core
Classification: Components
Component: DOM: IndexedDB (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 779638
Blocks: 438871
  Show dependency treegraph
 
Reported: 2012-07-27 09:46 PDT by Ed Morley [:emorley]
Modified: 2012-11-25 19:31 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Ed Morley [:emorley] 2012-07-27 09:46:37 PDT
Rev3 Fedora 12x64 mozilla-inbound debug test mochitests-2/5 on 2012-07-27 07:20:19 PDT for push c6b3dbee10d9

slave: talos-r3-fed64-041

https://tbpl.mozilla.org/php/getParsedLog.php?id=13908392&tree=Mozilla-Inbound

{
15825 INFO TEST-PASS | /tests/dom/indexedDB/ipc/test_ipc.html | /tests/dom/indexedDB/test/test_transaction_abort.html |  Abort should have fired!
15826 INFO TEST-PASS | /tests/dom/indexedDB/ipc/test_ipc.html | /tests/dom/indexedDB/test/test_transaction_abort.html |  Expect a null error for an aborted transaction - null should equal null
++DOMWINDOW == 18 (0x220de40) [serial = 264] [outer = 0x1ab9430]
--DOMWINDOW == 17 (0x2514120) [serial = 261] [outer = 0x29e4de0] [url = http://mochi.test:8888/tests/dom/indexedDB/test/third_party_iframe2.html]
--DOMWINDOW == 16 (0x29e4e60) [serial = 259] [outer = (nil)] [url = http://mochi.test:8888/tests/dom/indexedDB/test/third_party_iframe2.html]
--DOMWINDOW == 15 (0x2a1ca80) [serial = 249] [outer = 0x1e7be70] [url = http://mochi.test:8888/tests/dom/indexedDB/test/third_party_iframe2.html]
--DOMWINDOW == 14 (0x1e7bef0) [serial = 247] [outer = (nil)] [url = http://mochi.test:8888/tests/dom/indexedDB/test/third_party_iframe2.html]
--DOMWINDOW == 13 (0x1c27430) [serial = 243] [outer = (nil)] [url = http://mochi.test:8888/tests/dom/indexedDB/test/test_third_party.html]
--DOMWINDOW == 12 (0x2020cd0) [serial = 242] [outer = 0x1ab9430] [url = http://mochi.test:8888/tests/dom/indexedDB/test/test_success_events_after_abort.html]
2 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/indexedDB/test/test_transaction_lifetimes.html | request.transaction should still be set - got null, expected [object IDBTransaction @ 0x263cd70 (native @ 0x2e77090)]
}
Comment 1 Treeherder Robot 2012-07-27 18:11:52 PDT
mccr8
https://tbpl.mozilla.org/php/getParsedLog.php?id=13923653&tree=Mozilla-Aurora
Rev3 Fedora 12x64 mozilla-aurora debug test mochitests-2/5 on 2012-07-27 17:26:44
slave: talos-r3-fed64-052

2 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/indexedDB/test/test_error_events_abort_transactions.html | request.transaction should still be set
3 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/indexedDB/test/test_traffic_jam.html | expect it to be fired at the transaction - got [object IDBTransaction @ 0x1f42720 (native @ 0x1233380)], expected null
4 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/indexedDB/test/test_transaction_lifetimes.html | request.transaction should still be set - got null, expected [object IDBTransaction @ 0x139eb00 (native @ 0x2105a20)]
5 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/indexedDB/test/test_transaction_lifetimes.html | Should be able to get objectStore
6 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/indexedDB/test/test_transaction_lifetimes.html | Should be able to get index
7 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/indexedDB/test/test_transaction_lifetimes.html | Ordering is correct.
[Child 2241] ###!!! ABORT: aborting because of fatal error: file ../../../dom/ipc/ContentChild.cpp, line 629
[Child 2241] ###!!! ABORT: aborting because of fatal error: file ../../../dom/ipc/ContentChild.cpp, line 629
16424 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/indexedDB/test/test_add_put.html | This test left crash dumps behind, but we weren't expecting it to!
16432 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/indexedDB/test/test_add_twice_failure.html | This test left crash dumps behind, but we weren't expecting it to!
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
TEST-UNEXPECTED-FAIL | tab process 2241 | automationutils.processLeakLog() | missing output line for total leaks!
Comment 2 Treeherder Robot 2012-07-31 02:12:10 PDT
edmorley
https://tbpl.mozilla.org/php/getParsedLog.php?id=13984418&tree=Services-Central
Rev3 Fedora 12x64 services-central opt test mochitests-2/5 on 2012-07-30 17:08:21
slave: talos-r3-fed64-017

2544 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/devicestorage/test/test_basic.html | an unexpected uncaught JS exception reported through window.onerror - TypeError: can't access dead object at :0
2545 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/devicestorage/test/test_basic.html | an unexpected uncaught JS exception reported through window.onerror - TypeError: can't access dead object at :0
2552 INFO TEST-UNEXPECTED-FAIL | /tests/dom/devicestorage/test/test_dotdot.html | finished in a non-clean fashion (in /tests/dom/devicestorage/test/test_basic.html)
2 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/indexedDB/test/test_error_events_abort_transactions.html | request.transaction should still be set
3 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/indexedDB/test/test_traffic_jam.html | expect it to be fired at the transaction - got [object IDBTransaction], expected null
4 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/indexedDB/test/test_transaction_lifetimes.html | request.transaction should still be set - got null, expected [object IDBTransaction]
Comment 3 Treeherder Robot 2012-08-01 13:38:06 PDT
ryanvm%gmail.com
https://tbpl.mozilla.org/php/getParsedLog.php?id=14045121&tree=Mozilla-Inbound
Rev3 Fedora 12x64 mozilla-inbound opt test mochitests-2/5 on 2012-08-01 13:12:20
slave: talos-r3-fed64-004

2544 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/devicestorage/test/test_basic.html | an unexpected uncaught JS exception reported through window.onerror - TypeError: can't access dead object at :0
2 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/indexedDB/test/test_error_events_abort_transactions.html | request.transaction should still be set
3 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/indexedDB/test/test_traffic_jam.html | expect it to be fired at the transaction - got [object IDBTransaction], expected null
4 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/indexedDB/test/test_transaction_lifetimes.html | request.transaction should still be set - got null, expected [object IDBTransaction]
Comment 4 Treeherder Robot 2012-08-01 15:04:00 PDT
terrence
https://tbpl.mozilla.org/php/getParsedLog.php?id=14019626&tree=Try
Rev3 Fedora 12 try opt test mochitests-2/5 on 2012-07-31 17:43:10
slave: talos-r3-fed-015

2 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/indexedDB/test/test_error_events_abort_transactions.html | request.transaction should still be set
3 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/indexedDB/test/test_transaction_lifetimes.html | request.transaction should still be set - got null, expected [object IDBTransaction]
[Child 2223] ###!!! ABORT: aborting because of fatal error: file ../../../dom/ipc/ContentChild.cpp, line 643
[Child 2223] ###!!! ABORT: aborting because of fatal error: file ../../../dom/ipc/ContentChild.cpp, line 643
16750 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/indexedDB/test/test_add_put.html | This test left crash dumps behind, but we weren't expecting it to!
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 5 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-08-02 09:37:03 PDT
Should be fixed by Bug 779638.

Note You need to log in before you can comment on or make changes to this bug.