Last Comment Bug 779638 - Don't clear the request's transaction in IDBChild::Recv[Success|Error] since it may be too early
: Don't clear the request's transaction in IDBChild::Recv[Success|Error] since ...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: IndexedDB (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla17
Assigned To: Kyle Huey [:khuey] (khuey@mozilla.com)
:
Mentors:
Depends on:
Blocks: 766642 769624 778180
  Show dependency treegraph
 
Reported: 2012-08-01 14:12 PDT by Kyle Huey [:khuey] (khuey@mozilla.com)
Modified: 2012-08-06 16:31 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Patch (1.89 KB, patch)
2012-08-01 14:12 PDT, Kyle Huey [:khuey] (khuey@mozilla.com)
khuey: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
Details | Diff | Review

Description Kyle Huey [:khuey] (khuey@mozilla.com) 2012-08-01 14:12:46 PDT
Created attachment 648078 [details] [diff] [review]
Patch

Got r=bent irl.
Comment 1 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-08-01 14:16:19 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/0f2965ada1cd
Comment 2 Ryan VanderMeulen [:RyanVM] 2012-08-01 19:38:47 PDT
https://hg.mozilla.org/mozilla-central/rev/0f2965ada1cd
Comment 3 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-08-06 08:26:56 PDT
Comment on attachment 648078 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Implementing IndexedDB for e10s
User impact if declined: Annoyance to the sheriffs.
Testing completed (on m-c, etc.): Spent a week on m-c, kills orange dead.
Risk to taking this patch (and alternatives if risky): Very low risk.
String or UUID changes made by this patch: None.

Lets take this on Aurora to avoid oranges.  This code isn't actually used (it's for B2G) in any shipping product, but it is tested.
Comment 4 Lukas Blakk [:lsblakk] use ?needinfo 2012-08-06 16:14:55 PDT
Comment on attachment 648078 [details] [diff] [review]
Patch

much love for things that kill orange dead.  land away!
Comment 5 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-08-06 16:31:30 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/eaa94120ccbb

Note You need to log in before you can comment on or make changes to this bug.