Last Comment Bug 778858 - Web runtime does not use OOP plugins outside of Windows Vista/7
: Web runtime does not use OOP plugins outside of Windows Vista/7
Status: RESOLVED FIXED
:
Product: Firefox Graveyard
Classification: Graveyard
Component: Webapp Runtime (show other bugs)
: unspecified
: All All
: -- normal
: Firefox 17
Assigned To: Nobody; OK to take it and work on it
: Jason Smith [:jsmith]
Mentors:
Depends on:
Blocks: 749792
  Show dependency treegraph
 
Reported: 2012-07-30 12:39 PDT by John Schoenick [:johns]
Modified: 2016-03-21 12:39 PDT (History)
3 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Enable OOP plugins in webapprt by default (978 bytes, patch)
2012-07-31 11:10 PDT, John Schoenick [:johns]
myk: review+
john: checkin+
Details | Diff | Review

Description John Schoenick [:johns] 2012-07-30 12:39:40 PDT
webrt seems to run plugins in-process by default on windows XP, which is undesirable.

Possible explanation:
https://bugzilla.mozilla.org/show_bug.cgi?id=771090#c5

webrt uses OOP on windows vista+ due to:
https://hg.mozilla.org/mozilla-central/rev/b39f4007be5a
Comment 1 John Schoenick [:johns] 2012-07-31 11:10:34 PDT
Created attachment 647605 [details] [diff] [review]
Enable OOP plugins in webapprt by default
Comment 2 John Schoenick [:johns] 2012-07-31 11:14:19 PDT
Comment on attachment 647605 [details] [diff] [review]
Enable OOP plugins in webapprt by default

dom.ipc.plugins.enabled lives in firefox.js and not all.js or webapprt/prefs.js - right now then, we only use OOP plugins on Windows Vista+ where they are forced, never on XP/OS X/Linux.

This adds the necessary prefs to webapprt/prefs.js, though an alternative would be migrating the prefs to all.js

Myk - are you the right person to review this?
Comment 3 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-07-31 11:16:22 PDT
I think we should really push to move this to all.js, but that's a bigger task. Can you at least make sure we have a bug on file?
Comment 4 John Schoenick [:johns] 2012-07-31 11:55:51 PDT
(In reply to :Gavin Sharp (use gavin@gavinsharp.com for email) from comment #3)
> I think we should really push to move this to all.js, but that's a bigger
> task. Can you at least make sure we have a bug on file?

I filed bug 779240 for this
Comment 5 Jason Smith [:jsmith] 2012-08-03 17:28:10 PDT
We might want to double-check that patch. I just patched mozilla central and built firefox with that patch, and I'm crashing every single time I try access plugin content in a web app.
Comment 6 Myk Melez [:myk] [@mykmelez] 2012-08-07 11:17:37 PDT
Comment on attachment 647605 [details] [diff] [review]
Enable OOP plugins in webapprt by default

I tested the patch on Mac OS X (64bit), Windows 7 (64bit), and Windows XP (32bit), and they all behaved as expected, loading Flash in a separate process and not crashing.
Comment 7 John Schoenick [:johns] 2012-08-07 15:17:47 PDT
Comment on attachment 647605 [details] [diff] [review]
Enable OOP plugins in webapprt by default

http://hg.mozilla.org/integration/mozilla-inbound/rev/d0d82983f678
Comment 8 John Schoenick [:johns] 2012-08-07 15:19:31 PDT
(In reply to Jason Smith [:jsmith] from comment #5)
> We might want to double-check that patch. I just patched mozilla central and
> built firefox with that patch, and I'm crashing every single time I try
> access plugin content in a web app.

I couldn't reproduce this either - OOP seems to work fine in linux, and the flash apps I tried work. Does your build for this include the fix for bug 771090?
Comment 9 Jason Smith [:jsmith] 2012-08-07 15:26:17 PDT
(In reply to John Schoenick [:johns] from comment #8)
> (In reply to Jason Smith [:jsmith] from comment #5)
> > We might want to double-check that patch. I just patched mozilla central and
> > built firefox with that patch, and I'm crashing every single time I try
> > access plugin content in a web app.
> 
> I couldn't reproduce this either - OOP seems to work fine in linux, and the
> flash apps I tried work. Does your build for this include the fix for bug
> 771090?

I think so, but this is probably a problem on my end (I just recently started doing direct builds of Firefox with patches, so I probably screwed something up on my end).
Comment 10 Ed Morley [:emorley] 2012-08-08 09:32:09 PDT
https://hg.mozilla.org/mozilla-central/rev/d0d82983f678

Note You need to log in before you can comment on or make changes to this bug.