Autocomplete email address in compose mail window doesn't search based on second word in any field

RESOLVED DUPLICATE of bug 558931

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 558931
6 years ago
6 years ago

People

(Reporter: Mikeyy, Unassigned)

Tracking

13 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Hi,

Problem: TB can't seach based on second word in name, lastname or email fileds (or any other field)

For example

Name: John Mary
Lastname: Smith
Email: john.mary.smith@email.com

If you enter "mary" in to, cc or bcc autocomplete will find nothing since that word is second in name field and not first in email field.

If you enter "smith" it will find contacts only because lastname has first word "Smith", but if you enter "john" it will find contact based on 2 fields, name and email address.

Can this be fixed so it's searching all words in fileds and all parts of email address?

Comment 1

6 years ago
Hi Mihovil,

thanks & very true. Tracked here:

Bug 558931 - Autocomplete does not show all matching address book entries (implement partial/substring matching for each of multiple search words; find second words etc.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 558931
You need to log in before you can comment on or make changes to this bug.