speed up arrow panel opening animation

RESOLVED FIXED in Firefox 16

Status

()

Toolkit
Themes
--
enhancement
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: asa, Assigned: dao)

Tracking

Trunk
mozilla17
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox16 fixed)

Details

(Whiteboard: [good first bug][mentor=jaws][lang=css])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
The arrow panel animations are nice, but they're too slow. We need the panel to fade in a bit faster and the slide-down to happen in about half the current time (estimates from me, shorlander, and jaws)
The changes to the times would be made here:
http://mxr.mozilla.org/mozilla-central/source/toolkit/themes/pinstripe/global/popup.css#31
and here:
http://mxr.mozilla.org/mozilla-central/source/toolkit/themes/winstripe/global/popup.css#39
Whiteboard: [good first bug][mentor=jaws][lang=css]
Version: unspecified → 17 Branch
(Assignee)

Comment 2

5 years ago
Created attachment 647778 [details] [diff] [review]
patch

125ms for the sliding looked weirdly jumpy, but 150ms seems to work fine. Tested on Windows.
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #647778 - Flags: review?(shorlander)
(Assignee)

Updated

5 years ago
Summary: speed up arrow panel animation → speed up arrow panel opening animation
Version: 17 Branch → Trunk
(Assignee)

Updated

5 years ago
No longer blocks: 767133
Severity: normal → enhancement
Depends on: 767133
Comment on attachment 647778 [details] [diff] [review]
patch

Review of attachment 647778 [details] [diff] [review]:
-----------------------------------------------------------------

This feels more responsive. Thank you!
Attachment #647778 - Flags: review?(shorlander) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
https://hg.mozilla.org/integration/mozilla-inbound/rev/460e23aef181
Flags: in-testsuite-
Keywords: checkin-needed
Target Milestone: --- → mozilla17
Comment on attachment 647778 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): new feature in bug 767133 & bug 767861
User impact if declined: arrow panels (doorhangers, bookmarks properties) will open slower than desired
Testing completed (on m-c, etc.): tested locally, just landed on inbound
Risk to taking this patch (and alternatives if risky): no risk
String or UUID changes made by this patch: none
Attachment #647778 - Flags: approval-mozilla-aurora?

Comment 6

5 years ago
https://hg.mozilla.org/mozilla-central/rev/460e23aef181
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Comment on attachment 647778 [details] [diff] [review]
patch

fixes for a new feature in 16, approving for aurora.
Attachment #647778 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/025cea007fcb
status-firefox16: --- → fixed
You need to log in before you can comment on or make changes to this bug.