Implement OpenDescriptorForDirectTexturing for X11 pixmaps

RESOLVED DUPLICATE of bug 947045

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 947045
6 years ago
4 years ago

People

(Reporter: nical, Unassigned)

Tracking

(Blocks: 2 bugs)

Trunk
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
This would enable us to benefit from optimizations we are making with gralloc for gonk/fennec when we use accelerated layers.

see ShadowLayerManager::OpenDescriptorForDirectTexturing in ShadowLayerUtilsX11.cpp

http://mxr.mozilla.org/mozilla-central/source/gfx/layers/ipc/ShadowLayerUtilsX11.cpp#199
(Reporter)

Updated

6 years ago
Blocks: 722012
Blocks: 801286
Blocks: 801289
Blocks: 802031
I don't see this function being called at all?
We used to use the ShadowLayerUtils API to abstract away the differences between shmem/gralloc etc. We've moved away from that (though not completely :( ) with all the refactorings, so parts of it aren't used any more.

We now have separate TextureSource implementations for gralloc, and we'd need to do the same for X11 surfaces.
This function was removed at some point, I pretty sure we implemented what this asked for with bug 947045.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 947045
You need to log in before you can comment on or make changes to this bug.