OMTC slow down page scrolling

RESOLVED WORKSFORME

Status

()

Core
Graphics: Layers
RESOLVED WORKSFORME
5 years ago
3 months ago

People

(Reporter: Adrien CLERC, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10slater)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 671747 [details]
GLXInfo on a PC for which FF Nightly w/ OMTC is slower than stable 16.0.1

User Agent: Mozilla/5.0 (X11; Linux i686; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 2012101000

Steps to reproduce:

Use Nightly with OMTC enabled.
I go to a long page (http://en.wikipedia.org/wiki/Paris), and try to scroll with mouse, or with drag'n'drop on the scrollbar.


Actual results:

Scrolling is really slow, either with the mouse wheel or the scrollbar.


Expected results:

It should have been smooth, as in FF 16.0.1
(Reporter)

Updated

5 years ago
Blocks: 722012
Depends on: 779356

Comment 1

5 years ago
Same issue for me :
Firefox 19.0a1
Mozilla/5.0 (X11; Linux x86_64; rv:19.0) Gecko/19.0 Firefox/19.0
The slowness is from low to high depending of the page.

Comment 2

5 years ago
Created attachment 671769 [details]
glxinfo for foxxm
Mass tracking-e10s flag change. Filter bugmail on "2be0fcce-e36a-4e2c-aa80-0e3d33eb5406".
tracking-e10s: --- → +
tracking-e10s: + → later

Comment 4

3 months ago
WFM using current nightly.
Can you still reproduce when using a current version?
Flags: needinfo?(hermes1983)
Whiteboard: [closeme 2017-08-15]
(Reporter)

Comment 5

3 months ago
Except the fact that the previous setting to enable OMTC is not there anymore (layers.offmainthreadcomposition.enabled), I cannot reproduce this anymore in Nightly.
If you have any information about how to enable/disable OMTC. I'll be glad to recheck one last time.
Flags: needinfo?(hermes1983) → needinfo?(vseerror)

Comment 6

3 months ago
ISTM we just close this WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 months ago
Flags: needinfo?(vseerror)
Resolution: --- → WORKSFORME

Updated

3 months ago
Whiteboard: [closeme 2017-08-15]
You need to log in before you can comment on or make changes to this bug.