Compile error on Windows js shells involving zlib

VERIFIED FIXED in mozilla17

Status

()

Core
JavaScript Engine
--
blocker
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: gkw, Assigned: Benjamin)

Tracking

Other Branch
mozilla17
All
Windows 7
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 647794 [details]
stdout

There is a compile error on Windows js shells involving zlib, see attached log.
(Reporter)

Comment 1

5 years ago
This suggested patch by Benjamin over IRC does not work:

diff -r 162b401d8774 js/src/jsutil.h
--- a/js/src/jsutil.h   Tue Jul 31 17:35:46 2012 -0700
+++ b/js/src/jsutil.h   Tue Jul 31 17:43:50 2012 -0700
@@ -10,17 +10,19 @@
 
 #ifndef jsutil_h___
 #define jsutil_h___
 
 #include "mozilla/Attributes.h"
 
 #include "js/Utility.h"
 
+#ifdef USE_ZLIB
 #include "zlib.h"
+#endif
 
 /* Forward declarations. */
 struct JSContext;
 
 static JS_ALWAYS_INLINE void *
 js_memcpy(void *dst_, const void *src_, size_t len)
 {
     char *dst = (char *) dst_;
(Reporter)

Comment 2

5 years ago
I was using pymake on mozilla-central changeset 02346e2e7156.
(Reporter)

Comment 3

5 years ago
I used (with MozillaBuild and Visual Studio 2010):

--disable-optimize --enable-debug --enable-methodjit --enable-type-inference --enable-more-deterministic --disable-tests

The patch in bug 779393 does not fix this.
(Reporter)

Comment 4

5 years ago
(In reply to Gary Kwong [:gkw, :nth10sd] from comment #1)
> This suggested patch by Benjamin over IRC does not work:

On further checking, the patch in comment 1 (in conjunction with the patch in bug 779393) does make it work. Something else in my harness is making it fail but that's out of the scope of this bug.
(Assignee)

Comment 5

5 years ago
Created attachment 647829 [details] [diff] [review]
add missing #ifdef
Assignee: general → bpeterson
Attachment #647829 - Flags: review?(jorendorff)
Attachment #647829 - Flags: review?(jorendorff) → review+
(Reporter)

Comment 6

5 years ago
This should land as soon as possible once mozilla-inbound is reopened.
Keywords: checkin-needed
(Assignee)

Comment 7

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/ac7b1d3e3d83
(Reporter)

Updated

5 years ago
Keywords: checkin-needed
(Reporter)

Comment 8

5 years ago
in-testsuite- because this fixes a compile error.
Flags: in-testsuite-
(Reporter)

Comment 9

5 years ago
This was likely caused by bug 777190.
(Reporter)

Updated

5 years ago
Blocks: 777190
https://hg.mozilla.org/mozilla-central/rev/ac7b1d3e3d83
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla17
(Reporter)

Updated

5 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.