"Oops! We had an error." page displayed when deleting a developer profile.

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
6 years ago
6 years ago

People

(Reporter: vcarciu, Unassigned)

Tracking

({regression})

x86_64
Windows 7
regression
Points:
---

Details

(Reporter)

Description

6 years ago
Prerequisites:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0

Steps to reproduce:
1.Login to marketplace and open any submitted app.
2.From "Manage developer profile" , create a new dev profile.
3.Try to delete the developer profile

Expected results:
Developer profile is deleted without any issue

Actual results:
Oops! We had an error." page displayed when deleting a developer profile.

NOTES:
Not reproducible on prod.
After pressing "Remove profile " twice, both fields were deleted even if "Oops.." page was displayed. Please see screencast for this bug below:

http://screencast.com/t/u2O4yi3TRVR

Comment 1

6 years ago
Issue is also reproducing on AMO https://addons-dev.allizom.org/en-US/developers/
Screencast for this issue http://screencast.com/t/jIPJd6GJw
http://sentry.dmz.phx1.mozilla.com/addons-dev/group/1716/


IntegrityError: (1451, 'Cannot delete or update a parent row: a foreign key constraint fails (`addons_dev_allizom_org_new`.`addons_collections`, CONSTRAINT `addons_collections_ibfk_4` FOREIGN KEY (`comments`) REFERENCES `translations` (`id`))')

Stacktrace (most recent call last):

  File "django/core/handlers/base.py", line 111, in get_response
    response = callback(request, *callback_args, **callback_kwargs)

  File "amo/decorators.py", line 156, in wrapper
    return f(*args, **kw)

  File "amo/decorators.py", line 148, in wrapper
    return f(*args, **kw)

  File "addons/decorators.py", line 32, in wrapper
    return f(request, addon, *args, **kw)

  File "amo/decorators.py", line 29, in wrapper
    return func(request, *args, **kw)

  File "devhub/decorators.py", line 34, in wrapper
    return fun()

  File "devhub/decorators.py", line 26, in <lambda>
    *args, **kw)

  File "amo/decorators.py", line 50, in wrapper
    return f(request, *args, **kw)

  File "devhub/views.py", line 580, in remove_profile
    delete_translation(addon, 'the_reason')

  File "translations/models.py", line 161, in delete_translation
    Translation.objects.filter(id=trans.id).delete()

  File "django/db/models/query.py", line 445, in delete
    collector.delete()

  File "django/db/models/deletion.py", line 62, in decorated
    func(self, *args, **kwargs)

  File "django/db/models/deletion.py", line 253, in delete
    query.delete_batch(pk_list, self.using)

  File "django/db/models/sql/subqueries.py", line 44, in delete_batch
    self.do_query(self.model._meta.db_table, where, using=using)

  File "django/db/models/sql/subqueries.py", line 29, in do_query
    self.get_compiler(using).execute_sql(None)

  File "django/db/models/sql/compiler.py", line 750, in execute_sql
    cursor.execute(sql, params)

  File "django/db/backends/mysql/base.py", line 86, in execute
    return self.cursor.execute(query, args)

  File "MySQLdb/cursors.py", line 173, in execute
    self.errorhandler(self, exc, value)

  File "MySQLdb/connections.py", line 36, in defaulterrorhandler
    raise errorclass, errorvalue
Target Milestone: --- → 2012-08-02
Target Milestone: 2012-08-02 → 2012-08-09
Assignee: nobody → ashort
Target Milestone: 2012-08-09 → 2012-08-16
After talking to basta about this, it seems like this is a result of hitting an edge case in MySQL replication.
Target Milestone: 2012-08-16 → 2012-08-23
I got rid of this page in bug 742902, but the issues are indicative of a bigger issue. Seems like something we don't need to worry about right now since it was caused by the db refresh.
Closing since this page has been removed.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
(In reply to Allen Short [:ashort] from comment #5)
> Closing since this page has been removed.

See comment 4. Bug's still valid and page is still up. We're just not linking to it anymore. And this is very much related to bug 779740.
Assignee: ashort → nobody
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Target Milestone: 2012-08-23 → ---
Is this fixed with our new mysql settings?
(Reporter)

Comment 8

6 years ago
I cant see "Manage developer profile" on MP anymore, but this issue is still reproducible on AMO.
This page is gone from Marketplace but issue persists on AMO.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.