If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Unable to install an application with unicode characters (UTF-8) within the name

VERIFIED FIXED in Firefox 17

Status

()

Firefox for Android
Web Apps
P1
normal
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: aaronmt, Assigned: wesj)

Tracking

({regression})

unspecified
Firefox 17
ARM
Android
regression
Points:
---

Firefox Tracking Flags

(firefox16 unaffected, firefox17 verified)

Details

(Whiteboard: [blocking-webrtandroid1+])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
E/GeckoConsole( 4296): [JavaScript Error: "DOMApplicationRegistry: Could not parse JSON: [Exception... "Component returned failure code: 0x8050000e (NS_ERROR_ILLEGAL_INPUT) [nsIScriptableUnicodeConverter.ConvertToUnicode]"  nsresult: "0x8050000e (NS_ERROR_ILLEGAL_INPUT)"  location: "JS frame :: chrome://browser/content/browser.js :: <TOP_LEVEL> :: line 5895"  data: no]" {file: "resource://gre/modules/Webapps.jsm" line: 126}]

1. Go to http://ed.agadak.net/app/
2. Install Ed's app that should contain Japanese characters in the name

This is only only currently affecting mozilla-central (might be a regression from bug 766604).


{
    "name": "テスト Ed Agadak テスト",
    "launch_path": "/app",
    "default_locale": "en-US",
    "icons": {
        "32": "/favicon.ico",
        "64": "/favicon.ico"
    },
    "description": "Ed Agadak",
    "locales": {},
    "developer": {
        "url": "http://ed.agadak.net",
        "name": "Edward Lee"
    }
}

--
Nightly (08/01)
Samsung Galaxy Nexus (Android 4.1.1)
(Reporter)

Updated

5 years ago
Whiteboard: [blocking-webrtandroid1?]
Hmm...bug 738298 also landed recently too, I think it's possible it might be that one too. Fabrice - Do you know?

I think it's failing in a function called "_loadJSONASync" in Webapps.jsm.
Yep, that's bug 738298. It merged to central, can you check again?
(Reporter)

Comment 3

5 years ago
Using a tinderbox mozilla-inbound from (08/02) this still occurs.
(Assignee)

Comment 4

5 years ago
fabrice, your code is throwing on that particular manifest. Are you going to be able to look into it?
(In reply to Wesley Johnston (:wesj) from comment #4)
> fabrice, your code is throwing on that particular manifest. Are you going to
> be able to look into it?

yes
(Assignee)

Comment 6

5 years ago
Assigning this so I don't feel like I'm ignoring it then. If you are too busy fabrice, I can grab this (but I'm not sure what you're doing wrong...)
Assignee: nobody → fabrice
What's strange about this bug is that it only appears to happen on Android. Why is that the case? Is it cause Android added additional UTF-8 handling in bug 766604?

Updated

5 years ago
Priority: -- → P1

Updated

5 years ago
Whiteboard: [blocking-webrtandroid1?] → [blocking-webrtandroid1+]
(Assignee)

Comment 8

5 years ago
Created attachment 650397 [details] [diff] [review]
Patch

Actually, I made us not even use this anymore and removing it fixes this.
Assignee: fabrice → wjohnston
Attachment #650397 - Flags: review?(mark.finkle)
Comment on attachment 650397 [details] [diff] [review]
Patch

Less is better. I am tempted to have you remove the two "Got callback" logs too.
Attachment #650397 - Flags: review?(mark.finkle) → review+
Wes - Does this need to be uplifted to Fx16?
(Assignee)

Comment 11

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/62f8e90be342

Hmm.. 16 is weird because the platform patch isn't there. So... no.
https://hg.mozilla.org/mozilla-central/rev/62f8e90be342
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 17
(Reporter)

Updated

5 years ago
Status: RESOLVED → VERIFIED
status-firefox17: affected → verified
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.