exorcise nsIEnumerator in favor of nsISimpleEnumerator

RESOLVED FIXED

Status

()

defect
P3
normal
RESOLVED FIXED
20 years ago
2 years ago

People

(Reporter: waterson, Assigned: erahm)

Tracking

({arch})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

20 years ago
...or some other more scripable interface.

I've started on this crusade several times only to be chopped at the knees by
lethargy or some other overwhelming circumstance.
Reporter

Comment 1

20 years ago
I'll do it. I swear.
Status: NEW → ASSIGNED
Target Milestone: M10

Updated

20 years ago
Depends on: 11598
Reporter

Comment 2

20 years ago
Moving out non-critical tasks.
Reporter

Comment 3

20 years ago
*** Bug 8790 has been marked as a duplicate of this bug. ***

Comment 4

20 years ago
In verifying bug 8790, I just wanted to point out that warren mentioned cleaning
up nsIBidirectionalEnumerator also... Including his original comment:

"Chris -- you started this, so I'll help you finish it. :-)

We should eradicate nsIEnumerator and nsIBidirectionalEnumerator from
throughout the codebase if we can, switching over to nsISimpleEnumerator.
Having both is bad because they're incompatible.

We probably should remove the class definitions from nsEnumeratorUtils.h and
replace them with function calls.

When we're done, we can rename nsISimpleEnumerator to nsIEnumerator too."
Reporter

Comment 5

20 years ago
maybe scc'll do it. he's got balls.
Target Milestone: M15 → M20

Comment 6

20 years ago
In fact, I'd like to use the even better enumerators where possible, i.e., |
nsIInputIterator|, |nsIOutputIterator|, |nsIForwardIterator|, |
nsIBidirectionalIterator|, |nsIRandomAccessIterator|, which will provide easy 
access to the |nsISimpleEnumerator| functionality that JS clients in particular 
still love
Assignee: waterson → scc
Status: ASSIGNED → NEW

Updated

20 years ago
Status: NEW → ASSIGNED

Comment 7

19 years ago
mass re-assigning to my new bugzilla account
Assignee: scc → scc
Status: ASSIGNED → NEW

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Keywords: arch

Updated

19 years ago
Depends on: 40722

Comment 8

17 years ago
I guess we missed the boat on these (by about a hemisphere).  Our collection
classes are pretty much frozen across the board; I don't see any realistic mass
resolution to this situation before 2.0.
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → WONTFIX

Updated

14 years ago
Component: XP Miscellany → XPCOM

Comment 9

7 years ago
Should this be closed just because this didn't make 2.0?
The nsIEnumerator is still declared obsolete so this work should be done some day. I've not found any other bug for this.

https://developer.mozilla.org/en-US/docs/XPCOM_array_guide
Status: RESOLVED → REOPENED
OS: Windows NT → All
Hardware: x86 → All
Resolution: WONTFIX → ---

Updated

7 years ago
Blocks: 834911

Updated

7 years ago
No longer blocks: 834911

Updated

6 years ago
Depends on: 856238
Assignee

Comment 10

2 years ago
Bug 792209 removed |nsIEnumerator.idl|.
Assignee: scc → erahm
Assignee

Updated

2 years ago
Status: REOPENED → RESOLVED
Closed: 17 years ago2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.