remove unused includes of the obsolete nsISupportsArray and nsIEnumerator in /mozilla

RESOLVED FIXED in mozilla23

Status

()

defect
--
trivial
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: aceman, Assigned: aceman)

Tracking

Trunk
mozilla23
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

25.99 KB, patch
neil
: review+
benjamin
: review+
Details | Diff | Splinter Review
This does not change any variables/function arguments, just removes includes from files where nsISupportsArray and nsIEnumerator are no longer used. They should have been removed by the patches removing their usage.
Posted patch patchSplinter Review
Tested by building Thunderbird and by compiling each touched file individually. Not sure if something may fail in the final link of Firefox. A try build would be appreciated.
Attachment #731388 - Flags: review?(neil)
Summary: remove unused includes of the obsolete nsISupportsArray and nsIEnumerator → remove unused includes of the obsolete nsISupportsArray and nsIEnumerator in /mozilla
Attachment #731388 - Flags: review?(benjamin)
Comment on attachment 731388 [details] [diff] [review]
patch

Well, it compiles on Windows at least.
Attachment #731388 - Flags: review?(neil) → review+
Compiles which app? I've tested TB on linux.
SeaMonkey, naturally ;-)
Good, so it is appropriate that we wait for confirmation on Firefox.
Attachment #731388 - Flags: review?(benjamin) → review+
Thanks!
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/3c6cd745bea0
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla23
You need to log in before you can comment on or make changes to this bug.