Last Comment Bug 77972 - Non-ascii name is garbled in the Reply-to field on the Account Manager mail panel
: Non-ascii name is garbled in the Reply-to field on the Account Manager mail p...
Status: RESOLVED FIXED
[ish2+]
: intl
Product: MailNews Core
Classification: Components
Component: Internationalization (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Thunderbird 10.0
Assigned To: Makoto Kato [:m_kato]
:
:
Mentors:
: 376444 632370 (view as bug list)
Depends on:
Blocks: 157673
  Show dependency treegraph
 
Reported: 2001-04-27 14:48 PDT by marina
Modified: 2011-11-09 21:15 PST (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
here is a screen shot to illustrate the account display problem (cyrillic charset is used) (132.29 KB, image/jpeg)
2002-03-06 10:57 PST, marina
no flags Details
here is an error you'll get in case you will send the mail with the incorrect display of the recipient name (110.37 KB, image/jpeg)
2002-03-06 10:59 PST, marina
no flags Details
fix (1.97 KB, patch)
2011-11-02 02:08 PDT, Makoto Kato [:m_kato]
mozilla: review+
Details | Diff | Splinter Review

Description marina 2001-04-27 14:48:58 PDT
Stesp to repro:
- open Account Wizard, Edit|Account setting;
- enter a non-ascii name into the Replyt- field ( cyrillic name
<marina@netscape.com>
 - close Mail, reopen;
//note: the non-ascii name is garbled on the Reply-to field
Comment 1 nhottanscp 2001-04-27 14:59:11 PDT
There is a regression bug 77967 today, is this also a regression?
Comment 2 ji 2001-04-27 15:14:42 PDT
After I enter some Japanese characters on Reply-to Address field, save it and go 
back to the same screen again, the Ja chars are saved as ASCII characters. For 
example, hiragana a is save as ascii "B". It happens on 04/26 build too. 
It doesn't look like a regression. Is that we can only be allowed to enter ascii 
in Reply-to Address field?
Comment 3 marina 2001-04-27 15:22:50 PDT
i don't think it is a regression. I remember that we could not enter
"nonasciiname<marina@netscape.com>" before.
Comment 4 marina 2001-04-27 15:31:21 PDT
in 2001-04-18 build the non-ascii string entered in the Reply-to field on thhe
account wizard is not remembred after you close/reopen Mail, it is just lost. So
in a way it is not a regression but a progress :-)
Comment 5 nhottanscp 2001-04-27 15:44:47 PDT
Reassign to putterman.
Comment 6 scottputterman 2001-04-27 17:38:15 PDT
reassigning to racham.
Comment 7 ji 2001-05-09 16:47:30 PDT
Same problem with BCC antoher address field on copy and folder settings window.
Comment 8 racham 2001-05-09 17:04:00 PDT
ji, 

Is this confirmed with today's build. Lately, fix to the similar problem has
been checked in. It was fixed at prefs level and that should ideally take care
of these kind of problems too. Please let me know. thanks.

bhuvan
Comment 9 marina 2001-05-09 17:43:45 PDT
can not reproduce in 2001-05-09 ; non-ascii chars are saved correctly
Comment 10 ji 2001-05-10 09:47:06 PDT
Just checked Mac 2001-05-10-04 mtrunk build. It has no problem with Latin-1
accented characters, but Japanese characters are garbled. And this happens both
on Reply-to and BCC to other address field. I'll check win32 and linux build
when testable builds are available.
Comment 11 marina 2001-05-10 10:06:35 PDT
with Win 2001-05-09-04 build JA chars can not be saved correctly in any field
Comment 12 marina 2002-03-06 10:54:24 PST
this problem still exists in mozilla builds , charset that is non-latin1 can not
be correctly saved on the Account manager. For .ex would i use a cyrillic name
for the Reply-to field on english system it would be saved incorrectly. If the
user doesn't know that because the name displays correctly while being typed he
would not understand why he sees garbage in the composition window on the
Reply-to field (and CC and Bcc). This type of mail would not be sent in current
builds because the recipient is not recognized a valid.This is a serious
problem, and needs to be fixed. Nominating 
Comment 13 marina 2002-03-06 10:57:08 PST
Created attachment 72814 [details]
here is a screen shot to illustrate the account display problem (cyrillic charset is used)
Comment 14 marina 2002-03-06 10:59:04 PST
Created attachment 72816 [details]
here is an error you'll get in case you will send the mail with the incorrect display of the recipient name
Comment 15 racham 2002-03-06 11:32:46 PST
The Reply-to field is on AccountManager's main panel. Changing the summary to
reflect the same.
Comment 16 Michael Buckland 2002-03-15 17:14:11 PST
Discussed in Mail News bug meeting with Engineering, QA, Mktng and PjM. 
Decision was to plus this bug.
Comment 17 scottputterman 2002-03-21 10:57:12 PST
I'm going to minus this because if the user just types their email address in
then it will work, ie <marina@netscape.com>

Scott
Comment 18 nhottanscp 2002-08-06 14:31:05 PDT
nominate for nsbeta1
Comment 19 marina 2002-08-14 15:13:47 PDT
 The account wizard has three fields: "Account name" (this one accepts non-ascii
names), "Email address" ( this one is explicitly saying that only emails are
expected to be entered ) but in the third field we say :"Reply-to Address" and
the user could try to enter the pretty name here like "yourname@xyz.com". This
field doesn't accept pretty names , the non-ascii string enter here will be
saved as gibberish. So we have a choice to either change the code (in many
places) to be able to save the string in unicode (probably too late for this
release) or maybe change the wording for Reply-to address to make it clear that
ONLY email address (no pretty name) is going to be collected. Jennifer, what's
your take on this? Cc'ing Jennifer and Scott.  
Comment 20 jglick 2002-08-15 11:59:40 PDT
>or maybe change the wording for Reply-to address to make it clear that
>ONLY email address (no pretty name) is going to be collected.

"Reply-to Email Address:" (sorta long) or "Reply-to Email:" (not sure about 
this one)?
Comment 21 robinf 2002-08-15 12:08:50 PDT
I prefer "Reply-to Email Address:" if space allows. This is a more descriptive
label than "Reply-to Email:" . Including the phrase "Email Address" is the
clearest way to describe what we're asking for.
Comment 22 marina 2002-08-15 12:18:54 PDT
The "Reply-to Email Address" sounds good to me... one question though: do we
want to permanently exclude the use of pretty name for the Reply? The "From"
field is made of a combination of two strings: "Your name" and " Email address".
The fact that "Your name" field accepts non-ascii chars allows us to enter a
Name in japanese, chinese etc... The Reply then will only include the email
address though the user could have a different Display name associated with a
reply address... I am thinking how consistent is this design..?
Comment 23 jglick 2002-08-20 11:03:36 PDT
OK, i think i understand better now. "PrettyName <email@server.com>" works with 
ascii chars but "PrettyName" gets messed up when using non-ascii characters. I 
would think the best solution would be to allow non-ascii characters for 
PrettyName.
Comment 24 Simon Montagu :smontagu 2002-11-22 15:22:30 PST
Greg, another bug for your consideration.
Comment 25 Samir Gehani 2003-01-14 02:07:33 PST
Mail triage team: nsbeta1-
Comment 26 (not reading, please use seth@sspitzer.org instead) 2003-05-08 10:06:37 PDT
mass re-assign.
Comment 27 Mike Cowperthwaite 2004-12-28 07:03:55 PST
Comment on attachment 72816 [details]
here is an error you'll get in case you will send the mail with the incorrect display of the recipient name

This attachment is not useful because the error message being shown is about
the lack of a To: address in the email; it's unrelated to the Reply-To problem.

It is true that Unicode characters (beyond 0xFF) 
are stored oddly, as shown in attachment 72814 [details].  In Mozilla 1.8a6, an illegal
Reply-To header is simply left off the new message; but in TB 1.0, such a
header is truncated at the first illegal character -- see bug 208577.
Comment 28 Gonzalo HIGUERA DÍAZ 2007-04-03 05:11:59 PDT
(In reply to comment #27)
> In Mozilla 1.8a6, an illegal
> Reply-To header is simply left off the new message; but in TB 1.0, such a
> header is truncated at the first illegal character -- see bug 208577.

Being a little pedantic and pointing to comment #23 and the cone I made in bug 208577 (number 6), I would like to stress that this is not limited to illegal characters (such as those in the email address) but also to any non-ASCII character (such as those one might use when preceding the address with a PrettyName).
Comment 29 Magnus Melin 2007-04-06 05:57:04 PDT
*** Bug 376444 has been marked as a duplicate of this bug. ***
Comment 30 Makoto Kato [:m_kato] 2011-11-02 02:08:04 PDT
Created attachment 571270 [details] [diff] [review]
fix
Comment 31 Makoto Kato [:m_kato] 2011-11-02 02:09:39 PDT
no easy way to write unit test because this is attribute.
Comment 32 Makoto Kato [:m_kato] 2011-11-02 17:56:28 PDT
*** Bug 632370 has been marked as a duplicate of this bug. ***
Comment 33 David :Bienvenu 2011-11-03 14:14:32 PDT
Comment on attachment 571270 [details] [diff] [review]
fix

thx for the patch
Comment 34 Makoto Kato [:m_kato] 2011-11-03 19:09:54 PDT
http://hg.mozilla.org/comm-central/rev/8bba60eda697

Note You need to log in before you can comment on or make changes to this bug.