Last Comment Bug 779836 - Cannot connect to irc.mozilla.org if there are auto-joined channels defined
: Cannot connect to irc.mozilla.org if there are auto-joined channels defined
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Instant Messaging (show other bugs)
: 15 Branch
: x86 Windows 7
: -- normal (vote)
: Thunderbird 16.0
Assigned To: Patrick Cloke [:clokep]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-02 06:40 PDT by Mike Conley (:mconley) - (needinfo me!)
Modified: 2012-08-03 06:58 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
+
fixed
+
fixed


Attachments
Patch v1 (untested) (524 bytes, patch)
2012-08-02 07:28 PDT, Patrick Cloke [:clokep]
mconley: review+
Details | Diff | Splinter Review
Patch v2 (by clokep) (873 bytes, patch)
2012-08-02 10:30 PDT, Mike Conley (:mconley) - (needinfo me!)
mconley: review+
standard8: approval‑comm‑aurora+
standard8: approval‑comm‑beta+
Details | Diff | Splinter Review

Description Mike Conley (:mconley) - (needinfo me!) 2012-08-02 06:40:11 PDT
STR:

1)  Create an IRC account connecting to irc.mozilla.org, and add an auto-joined channel, like #maildev.
2)  Try to connect the account

What happens?

The "Connecting" account activity indicator just keeps spinning in the "Instant messaging status" window, and I get the following errors in the error console:

Timestamp: 02/08/2012 9:37:03 AM
Error: Error running command 001 with handler RFC 2812:
{"rawMessage":":concrete.mozilla.org 001 mconleyTB :Welcome to the Mozilla IRC Network mconleyTB!Thunderbir@66.207.208.98","command":"001","params":["mconleyTB","Welcome to the Mozilla IRC Network mconleyTB!Thunderbir@66.207.208.98"],"servername":"concrete.mozilla.org"}
Source Code:
irc

Timestamp: 02/08/2012 9:37:03 AM
Error: [Exception... "'[JavaScript Error: "channel is not defined" {file: "resource:///components/irc.js" line: 901}]' when calling method: [prplIAccount::joinChat]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: resource:///components/imAccounts.js :: <TOP_LEVEL> :: line 658"  data: yes]
Source File: resource:///modules/ircHandlers.jsm
Line: 102

What's expected?

I should connect.


So far, I'm only seeing this in TB 15 beta. I'll try Earlybird next.
Comment 1 Mike Conley (:mconley) - (needinfo me!) 2012-08-02 06:45:34 PDT
This problem affects TB 15 and TB 16.

Daily does not appear to be affected.
Comment 2 Patrick Cloke [:clokep] 2012-08-02 07:23:23 PDT
So it looks like https://hg.mozilla.org/releases/comm-beta/rev/7b51c0455855 (https://hg.mozilla.org/comm-central/rev/f0160c7f11c9) actually depending on a previous landing (https://hg.mozilla.org/comm-central/rev/f03b55eda4ce), which did NOT land on comm-beta.

I'm spinning up a patch now.
Comment 3 Patrick Cloke [:clokep] 2012-08-02 07:28:58 PDT
Created attachment 648338 [details] [diff] [review]
Patch v1 (untested)

This is untested: I don't have comm-central/beta installed or the source available or a way to build it currently. The fix is fairly trivial though.
Comment 4 Mike Conley (:mconley) - (needinfo me!) 2012-08-02 10:29:19 PDT
Comment on attachment 648338 [details] [diff] [review]
Patch v1 (untested)

I can confirm that this fixes the bug.

Your patch, however, has Windows style line endings. I'll upload a fixed patch.
Comment 5 Mike Conley (:mconley) - (needinfo me!) 2012-08-02 10:30:36 PDT
Created attachment 648383 [details] [diff] [review]
Patch v2 (by clokep)

Patch with better line endings.
Comment 6 Mike Conley (:mconley) - (needinfo me!) 2012-08-03 06:58:47 PDT
comm-aurora: https://hg.mozilla.org/releases/comm-aurora/rev/ccec873292af
comm-beta: https://hg.mozilla.org/releases/comm-beta/rev/d30295ff2691

Note You need to log in before you can comment on or make changes to this bug.