Last Comment Bug 779852 - crash in mozilla::gl::TextureImageGLX::BindTexture with abort message: "X_GLXVendorPrivate: GLXBadPixmap; 858 requests ago: file /builds/slave/m-cen-lnx-ntly/build/toolkit/xre/nsX11ErrorHandler.cpp, line 157" on NVIDIA GPUs
: crash in mozilla::gl::TextureImageGLX::BindTexture with abort message: "X_GLX...
Status: RESOLVED DUPLICATE of bug 779786
[startupcrash]
: crash, regression, topcrash, verifyme
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: 17 Branch
: All Linux
: -- critical (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Milan Sreckovic [:milan]
Mentors:
Depends on:
Blocks: 605749
  Show dependency treegraph
 
Reported: 2012-08-02 07:59 PDT by Scoobidiver (away)
Modified: 2012-09-19 10:13 PDT (History)
9 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed


Attachments

Description Scoobidiver (away) 2012-08-02 07:59:49 PDT
It first appeared in 17.0a1/20120802. The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=582d4c67b3a7&tochange=588424024294
It's likely a regression from bug 779019.

Signature 	mozalloc_abort | NS_DebugBreak_P | X11Error More Reports Search
UUID	39bd82a0-3440-42f0-a6f7-a32442120802
Date Processed	2012-08-02 13:48:42
Uptime	4
Last Crash	11 seconds before submission
Install Age	14 seconds since version was first installed.
Install Time	2012-08-02 13:48:21
Product	Firefox
Version	17.0a1
Build ID	20120802030533
Release Channel	nightly
OS	Linux
OS Version	0.0.0 Linux 3.2.0-26-generic #41-Ubuntu SMP Thu Jun 14 17:49:24 UTC 2012 x86_64
Build Architecture	amd64
Build Architecture Info	family 6 model 37 stepping 5
Crash Reason	SIGSEGV
Crash Address	0x0
App Notes 	
OpenGL: NVIDIA Corporation -- GeForce 8800 GS/PCIe/SSE2 -- 3.3.0 NVIDIA 295.40 -- texture_from_pixmap
X_GLXVendorPrivate: GLXBadPixmap; 1930 requests agoxpcom_runtime_abort(###!!! ABORT: X_GLXVendorPrivate: GLXBadPixmap; 1930 requests ago: file /builds/slave/m-cen-lnx64-ntly/build/toolkit/xre/nsX11ErrorHandler.cpp, line 157)
EMCheckCompatibility	True

Frame 	Module 	Signature 	Source
0 	libmozalloc.so 	mozalloc_abort 	memory/mozalloc/mozalloc_abort.cpp:23
1 	libxul.so 	NS_DebugBreak_P 	xpcom/base/nsDebugImpl.cpp:423
2 	libxul.so 	X11Error 	toolkit/xre/nsX11ErrorHandler.cpp:157
3 	libGL.so.295.40 	libGL.so.295.40@0x767d5 	
4 	libGL.so.295.40 	libGL.so.295.40@0x6da5f 	
5 	libxul.so 	mozilla::gl::TextureImageGLX::BindTexture 	gfx/gl/GLContextProviderGLX.cpp:949
6 	libxul.so 	mozilla::layers::ThebesLayerBufferOGL::RenderTo 	GLContext.h:234
7 	libGL.so.295.40 	libGL.so.295.40@0xa255b 	
8 	libGL.so.295.40 	libGL.so.295.40@0x7b6fa 	

More reports at:
https://crash-stats.mozilla.com/report/list?signature=mozalloc_abort+|+NS_DebugBreak_P+|+X11Error
Comment 1 Scoobidiver (away) 2012-08-04 02:35:57 PDT
One comment says: "Right at startup. Works on a clean profile, so I guess the problem is an add-on."

I haven't found obvious correlations.
Comment 2 Ori Avtalion (salty-horse) 2012-08-04 03:35:14 PDT
I have the crash when starting a profile with many tabs 

Here are some tests I performed:
1) Safe mode works.
2) After disabling all extensions in safe mode, regular startup still crashes - this is with a single "restore session tab".
3) After disabling "Use hardware acceleration" in safe mode, regular startup works fine. It works fine even after I enabled all extensions.

"Use hardware acceleration" seems to be the culprit, as this is obviously an OpenGL error.
Comment 3 Ori Avtalion (salty-horse) 2012-08-04 03:41:57 PDT
Some of the crash report comments don't crash at startup. It may be due to WebGL use, or the flash plugin using hardware acceleration (isn't that a different process?)
Comment 4 Scoobidiver (away) 2012-08-04 05:27:58 PDT
(In reply to Ori Avtalion (salty-horse) from comment #3)
> Some of the crash report comments don't crash at startup.
Non-startup crashes are not related to this bug.
Comment 5 nemo 2012-08-18 09:19:32 PDT
So, if this is a regression from bug 779019
then shouldn't vlad own this one?
I ask because I've been stuck on the nightly from 2012-08-01 due to bug #780232 which is probably this bug...
Comment 6 Karl Tomlinson (back Dec 13 :karlt) 2012-08-20 14:19:26 PDT
Should be fixed via bug 779786.

*** This bug has been marked as a duplicate of bug 779786 ***
Comment 7 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-09-19 10:13:38 PDT
Adding verifyme to confirm that this crash is reproducible before and not after bug 779786 was fixed.

Note You need to log in before you can comment on or make changes to this bug.