Closed Bug 780280 Opened 9 years ago Closed 8 years ago

The Babylon Toolbar changes user settings without reverting them

Categories

(WebExtensions :: General, defect)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 788353

People

(Reporter: jorgev, Assigned: jorgev)

References

Details

From bug 721264 comment #26:

> After Uninstalling all Babylon Firefox Addons, and programs from add-remove
> programs and restarting Firefox, the following Remains:
> home Page and New Tab is Set to http://search.babylon.com/home
> Search bar is set to Babylon Search
> 
> These are controlled by the following about:config strings and values:
> 
> browser.babylon.HPOnNewTab;search.babylon.com
> browser.newtab.url;http://search.babylon.com/?tt=3112_3&babsrc=NT_def
> browser.search.defaultenginename;Search the web (Babylon)
> browser.search.order.1;Search the web (Babylon)
> browser.search.selectedEngine;Search the web (Babylon)
> browser.startup.homepage;http://search.babylon.com/home?tt=3112_3
> extensions.BabylonToolbar_i.newTab;true
> extensions.BabylonToolbar_i.newTabUrl;http://search.babylon.com/
> ?tt=3112_3&babsrc=NT_def
> keyword.URL;http://search.babylon.com/
> ?tt=3112_3&babsrc=KW_def&mntrId=d465b9c300000000000000216a81a978&q=
> 
> It's worth noting that Babylon also takes over IE as well. At the very least
> these values should be Reset when the add-on is disabled or Removed. There
> is a opt-in checkbox that is poorly worded on the Babylon installer that
> asks if current values should be saved for when the program is, however the
> majority of users will not read these values and will not choose to select
> this value.

And comment #37 in that same bug:

> Alright, well when I tell Babylon to save my current settings, it does
> restore my home page and search engine. However it leaves the following:
> 
> browser.babylon.HPOnNewTab;search.babylon.com
> browser.newtab.url;http://search.babylon.com/
> ?affID=55555&tt=3112_5&babsrc=NT_def
> extensions.BabylonToolbar_i.newTab;true
> extensions.BabylonToolbar_i.newTabUrl;http://search.babylon.com/
> ?affID=55555&tt=3112_5&babsrc=NT_def
> keyword.URL;http://search.babylon.com/
> ?affID=55555&tt=3112_5&babsrc=KW_def&mntrId=d465b9c300000000000000216a81a978&
> q=
> 
> Leaving users with a Babylon Search Engine in the search bar

Our requirement is that all settings that are changed on installation must be reset when the extension is removed, either from the Add-ons Manager or the application installer. The preferences starting with extensions.BabylonToolbar and browser.babylon don't matter because they have no effect in the browser when the add-on is gone, but the rest must be reset to their default value.

If Babylon wants to keep anything after uninstall (say, the Babylon search engine in the search box), it needs to request this at uninstall and it must be opt-in.

I'll contact Babylon about this and give an update when I have an estimate on when this will be fixed.
If babylon does want to be really nice they can remove the custom preferences too :) Just would be a nice little thing. Users who delete an extension usually expect that to delete "Everything" related to it unless otherwise specified.
We don't expect that for any add-on. If you uninstall the add-on and reinstall it, it can be desirable to recover it with the same customizations it had initially. Firefox doesn't delete its profiles when it is uninstalled for pretty much the same reasons.
But Firefox does give you the option to delete those profiles, which Babylon does not do.
Blocks: Babylon
Babylon have informed us that they have addressed their uninstall issues in their latest release, already available on Babylon.com. Can someone please test it again and post the following information:

1) Is Babylon installed with the third party opt-in screen or the regular add-on install dialog?
2) If you cancel the add-on install, are any settings changed in Firefox?
3) Does uninstalling the Babylon software remove the add-ons and revert the changed settings?
With the newest Babylon software the changes are still opt-out (homepage, search engine, new tab, etc.) and removing the toolbar does not revert these changes to the originals or even to Firefox default.
How is possible that even after removing all my Firefox profiles, uninstall babylon and also removing any file named babylon from the HDD and the windows registry, to still not be able to get rid of it in FF 17 ?
Tryed the new version: Same opt-in screen and all other stuff that are formerly quoted.
It happens that the toolbar came as FREE BABYLON TOOLBAR with many software setups and utilities (Brothersoft Downloader is a good example i am not sure what currently it has because i prefer not going back to that website)
So maybe it comeup with other hooks that are also installed alongwith the toolbar. Will run a test case and update soon. :)
I must correct here, its CNET DOWNLOADER not the brothersoft one(it has its similar story as the Babylon has i.e. The Brothersoft Toolbar).
Fixed.
Downloaded newest Version of Babylon from babylon.com, installed it into a Fresh Firefox profile profile, accepting all defaults. It installed Babylon Toolbar 1.5.0. Removing the Toolbar did not remove the settings from inside Firefox, but kept the Start Page, Search Engine, and New Tab Page.
Checking...
Fixed :)
Please check
Nope, you still haven't fixed it. 

The steps to reproduce are really quite simple:

1. Install Firefox 17.0.1 on your computer.
2. Go to Babylon.com, download and install babylon.
3. Install Babylon, accept all the default settings (Don't click anything except "next").
4. Open Firefox, accept the add-on installs, restart Firefox
5. See that Babylon has taken over your start page, search engine and new tab page.
6. Go to about:addons, uninstall Babylon Toolbar and any other add-ons. Restart Firefox
7. See that none of your settings are reverted to default.
8. Go to control panel, uninstall Babylon and Babylon toolbar, re-open Firefox, see your settings are all still there.

Babylon needs to remove the babylon stuff from firefox upon uninstall, which is not currently happening. It would be even better if it didn't change these things by default, but instead made the checkboxes unchecked by default :)
For revert to work, the user has to check the following check box during the installation process: "I allow my current homepage settings and default search settings to be stored for easy reverting later."

Screen shot:
http://s2.postimage.org/dt7eg48i1/revert.jpg
Reverting must *always* work. That's a requirement in our guidelines: https://developer.mozilla.org/en-US/docs/Addons/Add-on_guidelines
Ok, I tested the new Babylon 10 today. It has changed a few things in the experience:

First, the good news:

Uninstalling from inside Firefox does revert your prefs to default, no checkbox or anything needed.

Babylon is now using the about:new add-ons page when it's installed, which is a positive.

The Bad news:

Babylon will not allow you to install unless you let it take over the Search engine/Home page and new tab page. This should not be necessary, a user should be able to install the toolbar. The Installer calls them "mandatory services". fortunately these are Opt-In boxes, but they aren't necessary.

Babylon is coming bundled with Dealply, which Does not use the about:newaddons page. We should block this add-on separately.


So some good stuff has happened in the latest update. I think we should consider blocking all older versions of Babylon if users who had prefs changed in old versions can use this version to remove those prefs (I can try to find an old version of the add-on to test later today).
Screenshots from the new Babylon install process:

https://people.mozilla.com/~kmaglione/images/2c17ccb63a60b401.png
https://people.mozilla.com/~kmaglione/images/245713d3542407f4.png
https://people.mozilla.com/~kmaglione/images/48f487e88fc58b29.png

Oddly, the settings changes that I "opted" into did not actually take effect, as far as I can tell.
OK, we now have bug 837830 on file for Dealply.

I think the current install and uninstall experience is within our policies. If they want to require their users to opt-in to these changes for the software to be installed, that's okay. The screenshots show that they are being very transparent about it, which is sufficient in my opinion.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Actually, found one setting that isn't being reverted. Baylon adds itself to the Default Search Engines list, and upon uninstall it is not removed (though it isn't selected as default). Because this is the default list a reset of Firefox won't fix it.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Thanks for the report.
Working on it. Will update soon.
This is all being tracked on bug 788353. Let's call this a dupe, even if it's older.
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 788353
Component: Add-ons → General
Product: Tech Evangelism → WebExtensions
You need to log in before you can comment on or make changes to this bug.