Closed Bug 780349 Opened 8 years ago Closed 8 years ago

SocialAPI arrowpanel arrow looks bad on OS X

Categories

(Firefox :: Theme, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 802332

People

(Reporter: Dolske, Unassigned)

References

Details

Attachments

(1 file)

Attached image Screenshot
The arrow used on the white SocialAPI arrowpanel looks bad on OS X. It has 2 specific problems:

1) There is a double-image effect on the sides of the arrow. There's a diagonal line lighter than the pixels on either side of it. I suspect this was meant to be semitransparent, but was cut from a mockup where it was placed on white?

2) The white region of the arrow is actually pink -- #fffafa.

Screenshot attached.

This image resource is chrome://browser/skin/social/panelarrow-up.png
(and also -down/-horiz)

http://mxr.mozilla.org/mozilla-central/source/browser/themes/pinstripe/social/

Looks like this is OS X only, as 771826 didn't land new icons for Windows.
Hmm, also, is there a reason these icons differ in size from the regular OS X arrows? (see http://mxr.mozilla.org/mozilla-central/source/toolkit/themes/pinstripe/global/arrow/)

  chrome://global/skin/arrow/panelarrow-up.png is 39x16
  chrome://browser/skin/social/panelarrow-up.png is 40x21

Probably ought to make them the same unless there's a reason not to.

Finally, bug 771284 may make the whole thing moot.
(In reply to Justin Dolske [:Dolske] from comment #1)
> Hmm, also, is there a reason these icons differ in size from the regular OS
> X arrows? (see
> http://mxr.mozilla.org/mozilla-central/source/toolkit/themes/pinstripe/
> global/arrow/)
> 
>   chrome://global/skin/arrow/panelarrow-up.png is 39x16
>   chrome://browser/skin/social/panelarrow-up.png is 40x21
> 
> Probably ought to make them the same unless there's a reason not to.
> 
> Finally, bug 771284 may make the whole thing moot.

The shadow is part of the image and it is larger on the bottom.
Depends on: 771284
Duplicate of this bug: 782791
btw, the custom css for the social panels is removed in the patch for bug 779923
closing this, the arrow panel stuff was changed a long while ago, though there is a new bug 802332 for arrow issues
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 802332
You need to log in before you can comment on or make changes to this bug.