Last Comment Bug 780367 - java.lang.IllegalStateException: ScrollView can host only one direct child at android.widget.ScrollView.addView(ScrollView.java)
: java.lang.IllegalStateException: ScrollView can host only one direct child at...
Status: VERIFIED FIXED
[native-crash]
: crash, regression, topcrash
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: 17 Branch
: ARM Android
-- critical (vote)
: Firefox 17
Assigned To: Michael Comella (:mcomella) [not active on fennec/Bugzilla: contact me via IRC]
:
: Sebastian Kaspari (:sebastian)
Mentors:
Depends on:
Blocks: 686528
  Show dependency treegraph
 
Reported: 2012-08-04 02:06 PDT by Scoobidiver (away)
Modified: 2013-12-10 10:01 PST (History)
6 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
verified
verified
verified


Attachments
Patch (2.35 KB, patch)
2012-08-06 14:17 PDT, Michael Comella (:mcomella) [not active on fennec/Bugzilla: contact me via IRC]
sriram.mozilla: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
lukasblakk+bugs: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description User image Scoobidiver (away) 2012-08-04 02:06:57 PDT
It has been it by 4 users since 17.0a1/20120803. The regression range is:
hg.mozilla.org/mozilla-central/pushloghtml?fromchange=588424024294&tochange=89dcadd42ec4
It's likely a regression from bug 686528.

Here is a crash report: bp-a2eff7a4-6e88-4876-a39e-4e63a2120804.

java.lang.IllegalStateException: ScrollView can host only one direct child
	at android.widget.ScrollView.addView(ScrollView.java:241)
	at android.view.LayoutInflater.rInflate(LayoutInflater.java:743)
	at android.view.LayoutInflater.inflate(LayoutInflater.java:459)
	at android.view.LayoutInflater.inflate(LayoutInflater.java:396)
	at android.view.LayoutInflater.inflate(LayoutInflater.java:352)
	at org.mozilla.gecko.AboutHomeContent.inflate(AboutHomeContent.java:143)
	at org.mozilla.gecko.AboutHomeContent.init(AboutHomeContent.java:111)
	at org.mozilla.gecko.BrowserApp$AboutHomeRunnable.run(BrowserApp.java:528)
	at android.os.Handler.handleCallback(Handler.java:605)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:137)
	at android.app.ActivityThread.main(ActivityThread.java:4424)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:511)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:784)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:551)
	at dalvik.system.NativeStart.main(Native Method)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.IllegalStateException%3A+ScrollView+can+host+only+one+direct+child+at+android.widget.ScrollView.addView%28ScrollView.java%29
Comment 1 User image Michael Comella (:mcomella) [not active on fennec/Bugzilla: contact me via IRC] 2012-08-04 03:35:24 PDT
I saw this error while creating the patches in bug 686528. I thought I fixed it with removeAllViews() but I will investigate.
Comment 2 User image Scoobidiver (away) 2012-08-05 05:40:35 PDT
It's #4 top crasher over the last 3 days.
Comment 3 User image Naoki Hirata :nhirata (please use needinfo instead of cc) 2012-08-06 10:14:27 PDT
Affected for 17.
Comment 4 User image Michael Comella (:mcomella) [not active on fennec/Bugzilla: contact me via IRC] 2012-08-06 14:17:21 PDT
Created attachment 649415 [details] [diff] [review]
Patch

After an OOM cleanup of BrowerApp, AboutHomeContent.inflate() would get called in AboutHomeContent.onConfigurationChanged() before AboutHomeContent.init() was called from BrowserApp.

Made GeckoApp/BrowserApp call inflate() instead of onConfigurationChanged() to ensure it's only called after init() is.
Comment 5 User image Sriram Ramasubramanian [:sriram] 2012-08-06 14:38:24 PDT
Comment on attachment 649415 [details] [diff] [review]
Patch

Review of attachment 649415 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me.
Comment 6 User image Ryan VanderMeulen [:RyanVM] 2012-08-06 17:58:29 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/fad487db4ea9
Comment 7 User image Ed Morley [:emorley] 2012-08-07 07:35:12 PDT
https://hg.mozilla.org/mozilla-central/rev/fad487db4ea9
Comment 8 User image Sriram Ramasubramanian [:sriram] 2012-08-10 11:40:15 PDT
Comment on attachment 649415 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 686528
User impact if declined: Inflation of about:home will crash at times.
Testing completed (on m-c, etc.): Landed in m-c on 08/07
Risk to taking this patch (and alternatives if risky): None.
String or UUID changes made by this patch: None.
Comment 9 User image Lukas Blakk [:lsblakk] use ?needinfo 2012-08-10 12:07:11 PDT
Comment on attachment 649415 [details] [diff] [review]
Patch

Approving for Aurora but can someone please confirm if 15 is affected by this?
Comment 10 User image Scoobidiver (away) 2012-08-10 12:39:59 PDT
(In reply to Lukas Blakk [:lsblakk] from comment #9)
> Approving for Aurora but can someone please confirm if 15 is affected by
> this?
Aurora and Beta are currently unaffected, but will be once bug 686528 lands in branches.
Comment 11 User image Sriram Ramasubramanian [:sriram] 2012-08-10 12:50:37 PDT
As mentioned in comment #10, to land bug 686528 in beta, I would need approval for this.
Comment 12 User image Lukas Blakk [:lsblakk] use ?needinfo 2012-08-13 11:00:54 PDT
Comment on attachment 649415 [details] [diff] [review]
Patch

approving then, for Beta, please make sure all this lands today so that it goes into Beta 5 and we have time to make sure there aren't any serious regressions for this.
Comment 13 User image Michael Comella (:mcomella) [not active on fennec/Bugzilla: contact me via IRC] 2012-08-13 15:04:39 PDT
Please note that the patches in bug 686528 should land before this patch (and the patch in bug 780481 should also land in this series).
Comment 14 User image Ryan VanderMeulen [:RyanVM] 2012-08-13 18:06:57 PDT
This didn't apply cleanly to aurora, but the unbitrotting was pretty mechanical. That said, please look it over to make sure I didn't mess anything up.

https://hg.mozilla.org/releases/mozilla-aurora/rev/0000a76dc267

https://hg.mozilla.org/releases/mozilla-beta/rev/acf8046887e0
Comment 15 User image Ryan VanderMeulen [:RyanVM] 2012-08-13 19:07:38 PDT
This had to be backed out due to bustage from bug 686528.

https://hg.mozilla.org/releases/mozilla-aurora/rev/1b8af79d5194
https://hg.mozilla.org/releases/mozilla-beta/rev/09e2ae313229
Comment 16 User image Sriram Ramasubramanian [:sriram] 2012-08-14 14:07:46 PDT
Pushed to beta: https://hg.mozilla.org/releases/mozilla-beta/rev/d6cbf07e54ed
Comment 17 User image Sriram Ramasubramanian [:sriram] 2012-08-14 19:07:04 PDT
And to aurora: https://hg.mozilla.org/releases/mozilla-aurora/rev/e3985167ea1d
Comment 18 User image Cristian Nicolae (:xti) 2012-09-06 06:58:31 PDT
The last crash occurred almost a week ago on 17.0a1 build. I cannot reproduce it on any branch. Closing bug as verified fixed.

--
Device: Galaxy Note
OS: Android 4.0.4

Note You need to log in before you can comment on or make changes to this bug.