Copy and paste can result in invalid email address with trailing space; Address book doesn't handle invalid email addresses with whitespace or brackets (<a@b.com >) correctly

RESOLVED DUPLICATE of bug 286760

Status

RESOLVED DUPLICATE of bug 286760
6 years ago
5 years ago

People

(Reporter: fwsfws, Unassigned)

Tracking

14 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713134347

Steps to reproduce:

Pasted e-mail address with a space at the end of the domain.  I was not aware that the space existed when the address was copied.

A-First L-Name <name@domain.com >


Actual results:

The address created in messages:


A-First L-Name <"name"@domain.com >


Expected results:

The address created should be:


A-First L-Name <name@domain.com>

Comment 2

6 years ago
howdy y'all,

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:14.0) Gecko/20120713 Thunderbird/14.0

this shows up for me in tb14, also.

STR = 
- open the address book
- add a new contact
- put "test@example.com " in the email field without the quotes but WITH the trailing space
- save the new contact
- create a new msg
- open the contacts sidebar if it aint already open
- dbl-clk on the test contact to add it to the TO field

note that the item shows as ...
|"test"@example.com | [vbars added for clarity]

note that the pre-@ part now has double quotes that shouldn't be there. note the trailing space after the domain IS there still. 

[1] it seems tbird really otta remove trailing spaces from the domain part.
[2] the double quotes are entirely unneeded in this case since the trailing space is NOT in the pre-@ part.

please forgive the address part names. [*blush*] i don't know the proper name for each of the parts of an email address.

take care,
lee
(Reporter)

Comment 3

6 years ago
Mystery Solved - But still a bug. After thinking about how the problem occurred, I had copied a new e-mail address from the text of a message. It has been recreated as a test case with the following message text...

New address

name@domain.com

Address above.

When "name@domain.com" is highlighted for copying and then pasted, a blank space is added. This was confirmed two ways,

1 paste the copied address into a blank notepad message, save and open with a hex editor.

2 in a line of "a"s insert what was copied --

aaaaaaaa

aaaaname@domain.com aaaa

The file was saved and opened with a hex editor.

To confirm this, send yourself a message similar to the one I sent. Copy the address into a string of characters so the the space will be obvious.

The original message does not contain a space ASCII 20 after the "m" in the domain. The section of the original message

63 6F 6D 0D 0A 0D 0A 41 64 64
c o m CR LF CR LF a d d

61 61 61 61 6E 61 6D 65 40 64 6F 6D 61 69 6E 2E 63 6F 6D 20 61 61 61 61
a a a a n a m e @ d o m a i n . c o m SP a a a a

SP = Space

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120713 Thunderbird/14.0

Fred

ASCII Table reference:

http://www.asciitable.com/

HEX Editor

http://mh-nexus.de/en/

This version was prepared in notepad and pasted. All characters originally equally spaced.

63 6F 6D 0D 0A 0D 0A 41 64 64
c o m CR LF CR LF a d d

61 61 61 61 6E 61 6D 65 40 64 6F 6D 61 69 6E 2E 63 6F 6D 20 61 61 61 61
a a a a n a m e @ d o m a i n . c o m SP a a a a
Apart from whitespace, we should also deal with brackets in case they are added where TB only expects a plain email address: <test@asdf.com > should become |test@asdf.com| (vbars added for clarity)
Adjusting summary to previous comments (not tested yet)
Summary: Thunderbird Creates Invalid E-mail Address → Copy and paste can result in email address with spaces/whitespace; Address book doesn't handle invalid email addresses with whitespace or brackets (<a@b.com >) correctly
Summary: Copy and paste can result in email address with spaces/whitespace; Address book doesn't handle invalid email addresses with whitespace or brackets (<a@b.com >) correctly → Copy and paste can result in invalid email address with trailing space; Address book doesn't handle invalid email addresses with whitespace or brackets (<a@b.com >) correctly
Whiteboard: dupeme

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 286760

Updated

5 years ago
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.