Add a "graylist" of characters to Pymake

RESOLVED FIXED in mozilla17

Status

()

Core
Build Config
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: sid0, Assigned: sid0)

Tracking

Trunk
mozilla17
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 649267 [details] [diff] [review]
patch v1

Pymake errors out on native command lines like $(TOUCH) "(foo)" and %cl ... -I"C:/Program Files (x86)/..." when it shouldn't. Since I have no interest in writing a full-fledged shell parser, this is the solution I came up with instead.
Attachment #649267 - Flags: review?(khuey)
(Assignee)

Updated

5 years ago
Blocks: 585011
Attachment #649267 - Flags: review?(khuey) → review+
(Assignee)

Comment 1

5 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/d52cc7128720
(Assignee)

Comment 2

5 years ago
Committed to the pymake repository as well:
http://hg.mozilla.org/users/bsmedberg_mozilla.com/pymake/rev/7d221562bc4a
https://hg.mozilla.org/mozilla-central/rev/d52cc7128720
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla17
(Assignee)

Updated

5 years ago
Duplicate of this bug: 783936
You need to log in before you can comment on or make changes to this bug.