If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Error when compiling mozilla central code in /media/webrtc/trunk/src/common_audio/resampler.cc - shell metacharacter '(' in command line

RESOLVED DUPLICATE of bug 780612

Status

()

Core
Build Config
RESOLVED DUPLICATE of bug 780612
5 years ago
5 years ago

People

(Reporter: jsmith, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Lately, I've been running into a problem trying to compile mozilla central with pymake (make.py -f client.mk in the root directory of mozilla central) with this weird error showing up in the console output:


c:\Users\jsmith\Documents\mozilla-central\config\rules.mk:1025:0:native command 'cl InvokeClWithDependencyGeneration cl -Foresampler/resampler.obj -c   -D_WIN32_WINNT=0x0601 -DWINVER=0x0601 -DWIN32 -D_WINDOWS -DNOMINMAX -DPSAPI_VERSION=1 -D_CRT_RAND_S -DCERT_CHAIN_PARA_HAS_EXTRA_FIELDS -DWIN32_LEAN_AND_MEAN -D_ATL_NO_OPENGL -D_HAS_TR1=0 -D_HAS_EXCEPTIONS=0 -D_SECURE_ATL -DCHROMIUM_BUILD -DTOOLKIT_VIEWS=1 -DENABLE_REMOTING=1 -DENABLE_P2P_APIS=1 -DENABLE_CONFIGURATION_POLICY -DENABLE_INPUT_SPEECH -DENABLE_NOTIFICATIONS -DENABLE_GPU=1 -DENABLE_EGLIMAGE=1 -DUSE_SKIA=1 -D__STD_C -D_CRT_SECURE_NO_DEPRECATE -D_SCL_SECURE_NO_DEPRECATE -DENABLE_REGISTER_PROTOCOL_HANDLER=1 -DENABLE_WEB_INTENTS=1 -DENABLE_PLUGIN_INSTALLATION=1 -DWEBRTC_WIN -DWEBRTC_EXPORT -D__STDC_FORMAT_MACROS -DNDEBUG -DNVALGRIND -DDYNAMIC_ANNOTATIONS_ENABLED=0 -DUNICODE -D_UNICODE -I. -I../../../../../../../media/webrtc/trunk/src/common_audio<
 span cl
ass="moz-txt-tag">/.. -I../../../../../../../media/webrtc/trunk/src/common_audio/../.. -I../../../../../../../media/webrtc/trunk/src/common_audio/../../third_party/wtl/include -I../../../../../../../media/webrtc/trunk/src/common_audio/resampler/include -I../../../../../../../media/webrtc/trunk/src/common_audio/signal_processing/include -I"C:\Program Files (x86)\Microsoft DirectX SDK (June 2010)/include"    -TP -nologo -W3 -Gy -Fdgenerated.pdb -wd4800 -we4553 -GR- -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -O1 -Oy   -MD            -FI ../../../../../../dist/include/mozilla-config.h -DMOZILLA_CLIENT c:/Users/jsmith/Documents/mozilla-central/obj-i686-pc-mingw32/media/webrtc/trunk/src/common_audio/c
 ommon_au
dio_resampler/../../../../../../../media/webrtc/trunk/src/common_audio/resampler/resampler.cc': shell metacharacter '(' in command line

Talking with Tim, this had to do with the fact that my direct X sdk I have installed has a parenthesis in it. Could we patch this up so that way someone else doesn't hit the issue I hit?
Created attachment 653290 [details] [diff] [review]
WIP

This is a patch I wrote for an unrelated issue, but that I think would solve this problem as well. This is WIP and not fully tested, although it does pass the pymake test suite.
jsmith: your pymake is out of date. Please use the in-tree pymake (python topsrcdir/build/pymake/make.py) or update your pull of bsmedberg's repository.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 780612
BTW, using in-tree pymake is probably going to be best because of the constant stream of fixes coming to it.
You need to log in before you can comment on or make changes to this bug.