Last Comment Bug 780645 - browser_595601-restore_hidden.js needs to wait for all tabs to be restored before continuing with the second test
: browser_595601-restore_hidden.js needs to wait for all tabs to be restored be...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Session Restore (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 17
Assigned To: Tim Taubert [:ttaubert]
:
: Mike de Boer [:mikedeboer]
Mentors:
Depends on:
Blocks: 780423
  Show dependency treegraph
 
Reported: 2012-08-06 09:50 PDT by Tim Taubert [:ttaubert]
Modified: 2012-08-08 02:55 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v1 (1.09 KB, patch)
2012-08-06 09:50 PDT, Tim Taubert [:ttaubert]
felipc: review+
Details | Diff | Splinter Review

Description Tim Taubert [:ttaubert] 2012-08-06 09:50:12 PDT
Created attachment 649301 [details] [diff] [review]
patch v1

browser_595601-restore_hidden.js currently doesn't wait for all tabs to be restored. It proceeds when a specific number of tabs is restoring.

The two tests run in separate windows but if we start the second test before tabs from the first one finished loading, we'll sometimes not get the expected number of tabs restoring at the same time.

Thus, we'll need to wait until (isRestoring == 1) because we're notified before session store. We then should only continue using executeSoon() to let session store process the progress listener notification.
Comment 1 :Felipe Gomes (needinfo me!) 2012-08-06 16:49:04 PDT
Comment on attachment 649301 [details] [diff] [review]
patch v1

would it be good to add a brief comment explaining isRestoring == 1?
Comment 2 Tim Taubert [:ttaubert] 2012-08-06 16:50:02 PDT
(In reply to :Felipe Gomes from comment #1)
> would it be good to add a brief comment explaining isRestoring == 1?

Of course, will do that. Thanks!
Comment 3 Tim Taubert [:ttaubert] 2012-08-07 07:22:51 PDT
https://hg.mozilla.org/integration/fx-team/rev/fba2eb0c80ab
Comment 4 Tim Taubert [:ttaubert] 2012-08-08 02:55:24 PDT
https://hg.mozilla.org/mozilla-central/rev/fba2eb0c80ab

Note You need to log in before you can comment on or make changes to this bug.