<select> boxes don't show content

VERIFIED FIXED in Firefox 16

Status

()

Core
Layout: Form Controls
VERIFIED FIXED
5 years ago
3 years ago

People

(Reporter: sdwilsh, Assigned: mats)

Tracking

({regression, testcase})

Trunk
mozilla17
x86
All
regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(firefox16+ verified, firefox17+ verified)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
I'm seeing this bug on Facebook.  I've ruled out an issue on our end, so I'm pretty sure it's a Firefox bug.  The bug only happens on Nightly (I tried Aurora, Beta, and Release).

In any area on Facebook where we have a select that has a pop-up (not a real one, but a fake one), select drop downs will only show the selected option.  You can change the value with the keyboard, and the selected value displayed will update, but you can never see all your options.

A way to see this for yourself (these instructions assume you have timeline; if you don't I can provide alternate instructions):
1) After logging in, go to https://www.facebook.com/me (this will take you to your profile)
2) In the status update box, click "Life Event"
3) Select "Work & Education"
4) Select "Other Life Event..."
5) Try to change the year from 2012

This has been broken since at least early June (I just thought it was a bug on our end, but I've since proven that wrong AFAICT).
> 5) Try to change the year from 2012

The bug is that you only see one year (2012) in the drop-down box.  You should see many of them (the latest being 2012).

> these instructions assume you have timeline

My Facebook testing account didn't, so Shawn had to add it.

Here's the regression range:

firefox-2012-06-23-03-05-32-mozilla-central
firefox-2012-06-24-03-05-37-mozilla-central

Which translates into:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=bb4b37094b9f&tochange=cb2904476d14

I'll need to hg bisect to find which patch in this range triggered the bug.

Comment 2

5 years ago
I can reproduce in Aurora 16.0a2 and Nightly17.a1 on Windows7

Step To Reproduce:

1) After logging in, go to https://www.facebook.com/me (this will take you to your profile)
2) In the status update box, click "Life Event"
3) Select "Work & Education"
3-1) Scroll up so that header(Status Photo Place  Life Event) becomes outside a viewport --- (This may be necessary to reproduce the problem)
4) Select "Other Life Event..."
5) Try to change the year from 2012


Regression window(cached m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/bf37951c1104
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0a1 ID:20120623031143
Bad:
http://hg.mozilla.org/mozilla-central/rev/e21173ed2c38
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 ID:20120623053647
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=bf37951c1104&tochange=e21173ed2c38


Regression window(cached m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/80b8680bda1c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 ID:20120622175046
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/c35d2d3071ac
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 ID:20120622182843
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=80b8680bda1c&tochange=c35d2d3071ac
OS: Mac OS X → All
Here's the patch that caused/triggered this bug:

http://hg.mozilla.org/mozilla-central/rev/23f5c88adb8f

 Bug 575294. part=2/5 r=smaug,roc
author	Mats Palmgren <matspal@gmail.com>
	Sat Jun 23 03:13:56 2012 +0200 (at Sat Jun 23 03:13:56 2012 +0200)

Mats, any idea what's going on?
Blocks: 575294
Component: Widget: Cocoa → General
FWIW, here's another Example: http://www.angelsport.de/__WebShop__/product/111807-44_45/detail.jsf (maybe easier to repro than using FB)

If you try to change the "Größe" <select> twice, it's broken. I confirmed that the Range fits Comment 2/Comment 3.
(Reporter)

Updated

5 years ago
tracking-firefox16: --- → ?
Component: General → Widget: Cocoa
OS: All → Mac OS X
(Reporter)

Updated

5 years ago
Component: Widget: Cocoa → General
OS: Mac OS X → All

Updated

5 years ago
Duplicate of this bug: 780872

Comment 6

5 years ago
testcase is available in bug 780872
status-firefox16: --- → affected
status-firefox17: --- → affected
Keywords: regression

Comment 7

5 years ago
Created attachment 649679 [details]
Testcase

Updated

5 years ago
Attachment #649679 - Attachment mime type: text/plain → text/html
tracking-firefox17: --- → ?
(Assignee)

Updated

5 years ago
Component: General → Layout: Form Controls
Keywords: testcase
(Assignee)

Comment 8

5 years ago
Created attachment 649928 [details] [diff] [review]
fix

Probably the same issue as I filed in bug 775958, but I'll use this
bug instead since it has a testcase.  The bug is that once
mDropdownCanGrow is set to false it needs a reflow to be updated.
We need to reset that flag when positioning the frame, something
like this should work I think.

https://tbpl.mozilla.org/?tree=Try&rev=7a2374ce92a0
Assignee: nobody → matspal
(Assignee)

Updated

5 years ago
Blocks: 775958
tracking-firefox16: ? → +
tracking-firefox17: ? → +
(Assignee)

Comment 9

5 years ago
Created attachment 651931 [details] [diff] [review]
fix v2

https://tbpl.mozilla.org/?tree=Try&rev=2dccfe1e578f

Tested on Linux, OSX, Win7, with testcase in this bug,
bug 314939, bug 575294 and bug 726264.

I'll try to make a reftest run as a mochitest for this bug...
Attachment #649928 - Attachment is obsolete: true
Attachment #651931 - Flags: review?(roc)
Attachment #651931 - Flags: review?(roc) → review+
(Assignee)

Comment 10

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/f8d76d32e29b
Flags: in-testsuite?
Target Milestone: --- → mozilla17
https://hg.mozilla.org/mozilla-central/rev/f8d76d32e29b
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 12

5 years ago
Comment on attachment 651931 [details] [diff] [review]
fix v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 575294
User impact if declined: comboboxes appears to only display one option in its dropdown menu in some cases
Testing completed (on m-c, etc.): landed on m-c 2012-08-15
Risk to taking this patch (and alternatives if risky): medium - the patch is simple, but this code is very fragile and regression prone historically.  If denied, we probably have to backout bug 575294 and bug 726264 from Aurora
String or UUID changes made by this patch: none
Attachment #651931 - Flags: approval-mozilla-aurora?

Updated

5 years ago
status-firefox17: affected → fixed
(Assignee)

Updated

5 years ago
Duplicate of this bug: 783250
Comment on attachment 651931 [details] [diff] [review]
fix v2

Lets give it a try, we have another week before cutting 16 over to Beta to keep an eye on this for regressions.  We can fall back on backing out if that happens.
Attachment #651931 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 15

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/82a02621fc9b
status-firefox16: affected → fixed
Keywords: verifyme
Verified with Firefox 16 beta 4 that <select> boxes are showing content on Windows 7, Mac OS X 10.7 and Ubuntu 12.04 (verified on Facebook and using the test cases from the duplicate bugs).

Mozilla/5.0 (Windows NT 6.1; rv:16.0) Gecko/20100101 Firefox/16.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:16.0) Gecko/20100101 Firefox/16.0
Mozilla/5.0 (X11; Linux i686; rv:16.0) Gecko/20100101 Firefox/16.0
status-firefox16: fixed → verified
QA Contact: simona.marcu
Verified as fixed on Firefox 17 beta 1 -  <select> boxes are showing content on Windows 7, Mac OS X 10.7 and Ubuntu 12.04 (verified on Facebook and using the test cases from the duplicate bugs).

Mozilla/5.0 (Windows NT 6.1; rv:17.0) Gecko/17.0 Firefox/17.0
Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/17.0 Firefox/17.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:17.0) Gecko/17.0 Firefox/17.0
status-firefox17: fixed → verified
Depends on: 865702
Unfortunately, Mats, your patch for this bug seems to have caused/triggered yet another bug -- bug 865702.

Updated

4 years ago
Depends on: 876346

Updated

4 years ago
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.