Select options wrong position on dropdown after scrolling

VERIFIED FIXED

Status

()

Core
Layout: Form Controls
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: jtl.shopteam, Unassigned)

Tracking

({regression})

16 Branch
x86
All
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox21 affected, firefox22 fixed, firefox23 verified, firefox24 verified, firefox-esr17 wontfix)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 754359 [details]
firefox_select_options_bug.jpg

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.93 Safari/537.36

Steps to reproduce:

Load Page http://demoshop.jtl-software.de/Produkt-mit-unterschiedlichen-Variationen, scroll down and click on the selectbox "bitte wählen". 


Actual results:

Select options appear far below the selectbox. Distance between options and selectbox increases, the more you scroll down before clicking on the selectbox. 

Also see http://forum.jtl-software.de/fehler-bugs-jtl-shop3/55493-bug-bei-konfigurationsartikel.html (german) for more information on this topic. 


Expected results:

Select options should appear right below selectbox on click. Scrolling down should not have an effect.
(Reporter)

Updated

5 years ago
Summary: Select options wrong position on Dropdown after Scrolling → Select options wrong position on dropdown after scrolling

Comment 1

5 years ago
Could you update to the current version Firefox 21 and see if the issue is still here.

In addition, try with a new profile:
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

On my side, WFM with FF21 on Win 7. So maybe issue specific to OSX.
Flags: needinfo?(jtl.shopteam)

Updated

5 years ago
Component: Untriaged → Layout: Form Controls
Product: Firefox → Core

Comment 2

5 years ago
Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/ccf120bf4638
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120815073201
Bad:
http://hg.mozilla.org/mozilla-central/rev/0678e3e84923
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120815082402
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ccf120bf4638&tochange=0678e3e84923

Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/74649a7a17c8
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120814185400
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/f8d76d32e29b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120814192859
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=74649a7a17c8&tochange=f8d76d32e29b

Regressed by: 
f8d76d32e29b	Mats Palmgren — Bug 780661 - Update mDropdownCanGrow also when the position is currently outside viewport to allow a resize later at a different position. Also, don't call PositionFrameView unless the position really changed to avoid infinite number of calls to AbsolutelyPositionDropDown (via nsResizeDropdownAtFinalPosition event from NotifyGeometryChange). r=roc

Fixed window(m-c)
Bad:
http://hg.mozilla.org/mozilla-central/rev/00b264c7cced
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130522 Firefox/24.0 ID:20130522092949
Fixed:
http://hg.mozilla.org/mozilla-central/rev/8eebe35aae63
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130523 Firefox/24.0 ID:20130523044333
Fixed pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=00b264c7cced&tochange=8eebe35aae63


Fixed window(m-i)
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/87af5e1caacb
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130522 Firefox/24.0 ID:20130522222933
Fixed:
http://hg.mozilla.org/integration/mozilla-inbound/rev/87e9d2c528c0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130522 Firefox/24.0 ID:20130522223832
Fixed pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=87af5e1caacb&tochange=87e9d2c528c0

Fixed by:
87e9d2c528c0	Timothy Nikkel — Bug 865702. Don't move the frame in FinishReflowChild if we were told not to. r=roc

Updated

5 years ago
Blocks: 780661
Status: UNCONFIRMED → NEW
status-firefox21: --- → affected
status-firefox-esr17: --- → affected
tracking-firefox22: --- → ?
tracking-firefox23: --- → ?
tracking-firefox24: --- → ?
Depends on: 865702
Ever confirmed: true
Keywords: regression
OS: Mac OS X → All
Version: 20 Branch → 16 Branch

Updated

5 years ago
status-firefox24: --- → fixed
tracking-firefox24: ? → ---

Comment 3

5 years ago
Can you uplift the patch of Bug 865702 to Aurora23.0a1 and 22.0Beta, please.
Flags: needinfo?(tnikkel)

Comment 4

5 years ago
(In reply to Loic from comment #1)
> On my side, WFM with FF21 on Win 7. So maybe issue specific to OSX.

Sorry, I forgot to scroll, bug confirmed too.
Flags: needinfo?(jtl.shopteam)
(In reply to Alice0775 White from comment #3)
> Can you uplift the patch of Bug 865702 to Aurora23.0a1 and 22.0Beta, please.

This is a regression from 17? So it's been around for several releases. Given that this isn't very severe I doubt the drivers would approve a beta uplift, Aurora maybe.
Flags: needinfo?(tnikkel)
I approved the uplift over on bug 865702, no need to track here - we could even dupe this couldn't we?
status-firefox22: --- → affected
status-firefox23: --- → affected
tracking-firefox22: ? → ---
tracking-firefox23: ? → ---
We can at least mark it fixed, because it is fixed by bug 865702.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-firefox22: affected → fixed
status-firefox23: affected → fixed
Resolution: --- → FIXED
Verified fix on the build from https://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/23.0b4-candidates/build1/mac/en-US/
Status: RESOLVED → VERIFIED
Keywords: verifyme
Mozilla/5.0 (X11; Linux i686; rv:23.0) Gecko/20100101 Firefox/23.0
Mozilla/5.0 (Windows NT 6.1; rv:23.0) Gecko/20100101 Firefox/23.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:23.0) Gecko/20100101 Firefox/23.0

Verified as fixed on Firefox 23 beta 9 (buildID: 20130725195523) and latest Nightly (buildID: 20130725171558).
status-firefox23: fixed → verified
Verified as fixed on Firefox 24 beta 2:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0
Mozilla/5.0 (X11; Linux i686; rv:24.0) Gecko/20100101 Firefox/24.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:24.0) Gecko/20100101 Firefox/24.0
Build ID: 20130812173056
status-firefox24: fixed → verified
Keywords: verifyme
This doesn't meet ESR landing criteria, wontfixing for that branch.
status-firefox-esr17: affected → wontfix
You need to log in before you can comment on or make changes to this bug.