Last Comment Bug 781646 - Windows widget AudioSession::Start not working in Metro
: Windows widget AudioSession::Start not working in Metro
Status: RESOLVED FIXED
completed-elm
:
Product: Core
Classification: Components
Component: Widget: Win32 (show other bugs)
: Trunk
: x86_64 Windows 8.1
: -- normal (vote)
: mozilla17
Assigned To: Brian R. Bondy [:bbondy]
:
Mentors:
Depends on:
Blocks: 781649 781653
  Show dependency treegraph
 
Reported: 2012-08-09 13:55 PDT by Brian R. Bondy [:bbondy]
Modified: 2014-07-24 11:06 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1. (2.37 KB, patch)
2012-08-09 13:59 PDT, Brian R. Bondy [:bbondy]
jmathies: review+
Details | Diff | Review

Description Brian R. Bondy [:bbondy] 2012-08-09 13:55:08 PDT
AudioSession::Start is failing on Metro because COM is already initialized and returning an error.
Comment 1 Brian R. Bondy [:bbondy] 2012-08-09 13:59:32 PDT
Created attachment 650670 [details] [diff] [review]
Patch v1.

This is part of the stuff needed to get flash working in Metro but I separated this out since it can land on m-c.  CoInitialize is returning S_FALSE which causes the audio session to stay in an uninitialized state.

The other small change isn't needed but is more correct since the assertion is ignored in release mode and it would lead to a crash if uuidgen was ever not available.
Comment 2 Brian R. Bondy [:bbondy] 2012-08-09 14:06:40 PDT
http://hg.mozilla.org/projects/elm/rev/0f5f696f4f46
Comment 3 Brian R. Bondy [:bbondy] 2012-08-10 12:14:03 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/edb166cc85b9
Comment 4 Ryan VanderMeulen [:RyanVM] 2012-08-11 19:55:32 PDT
https://hg.mozilla.org/mozilla-central/rev/edb166cc85b9

Note You need to log in before you can comment on or make changes to this bug.