status bar should show account name when displaying account-specific activity

RESOLVED DUPLICATE of bug 66860

Status

Thunderbird
Mail Window Front End
--
enhancement
RESOLVED DUPLICATE of bug 66860
5 years ago
5 years ago

People

(Reporter: Lee_Dailey, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [DUPEME])

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713134347

Steps to reproduce:

checked mail [either automatically or manually]


Actual results:

status bar displayed "no messages to download"


Expected results:

the account that was checked should have been included in the status msg. for example - "no messages to download for [account name]"
(Reporter)

Comment 1

5 years ago
howdy y'all,

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:14.0) Gecko/20120713 Thunderbird/14.0

currently, if you have multiple accounts set up in tbird, the status bar msgs are _far_ too generic. for example ...
"2 messages downloaded"

in the activity manager, the same msg is displayed along with the account name. for example ...
"two messages downloaded
LD_ATT-Yahoo"

the account name really otta be shown on the status bar for any status msg that is account specific. something like one of these for example ...
"2 messages downloaded for LD_ATT-Yahoo"
"2 messages downloaded from LD_ATT-Yahoo"
"2 messages downloaded for account LD_ATT-Yahoo"

the third one makes the most sense to me, but that is open to debate. [*grin*] 

take care,
lee
(Reporter)

Updated

5 years ago
Summary: status bar should show account name when displaying activity → status bar should show account name when displaying account-specific activity

Comment 2

5 years ago
+1

if there are no dupes, this should be confirmed.

Updated

5 years ago
Severity: normal → enhancement

Updated

5 years ago
OS: Windows 7 → All
Hardware: x86 → All

Updated

5 years ago
Version: 13 → Trunk

Comment 3

5 years ago
My proposal would be:
[account] message

But there must be a dupe somewhere...
Component: General → Mail Window Front End
Whiteboard: [DUPEME]
(Reporter)

Comment 4

5 years ago
howdy  :aceman,

so you would use something like this ...
"2 LD_ATT-Yahoo messages downloaded"

that would work for me. it seems a tad awkward, but it works and may be easier to support other languages.

as for dupes ... it bumfuzzles me that there aren't any. even tho i searched and found nothing, i was expecting to be duped right quick. [*grin*] 

take care,
lee

Comment 5

5 years ago
I mean "LD_ATT-Yahoo: 2 messages downloaded.", "LD_ATT-Yahoo: No messages on server."

Comment 6

5 years ago
I found some:
Bug 245822, bug 309121, bug 333247, bug 288447, bug 689992.

So either we dupe this to some of them, or if you want this bug have so broadly defined (all account-specific activity), then it could be turned into a meta bug for the listed bugs.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 7

5 years ago
howdy :aceman,

your "account-name: status message" layout is really quite good! i like it rather a lot. [*grin*] 

i'm not sure how things are best done when something is this broadly defined. duping it to the others seems wrong in that they don't cover the subject well. i used the msg checking/downloading items as the most obvious example. 

if you think making it a meta would be effective, then please do so. i won't complain. [*grin*] most likely i will make a specific bug to replace bug 245822 since i don't think it can reasonably be reopened after 7 years.

take care,
lee

Comment 8

5 years ago
meta probably not even needed, especially if there is only one patch.

if only one patch, suggest make the fix here, and then dup other bug if it is found that it is fixed.

Comment 9

5 years ago
Oh and there is bug 66860 with a ton of dupes :)
It also has a patch! But the bug is a mess nowadays...

Wayne, I don't think this would be one patch, as the messages seem to be generated by various C++ code.
(Reporter)

Comment 10

5 years ago
howdy y'all,

i thot there otta be an earlier request for this. [*grin*] thank you for finding it!

bug 66860 discusses server name versus account name. i _think_ it finally settled on account name. that is [in my opinion] _far_ more useful than server name. especially since several accounts can point to the same server.

they also seem to have settled on account name first.

it seems to cover the entire idea i was looking at. since i'm not well informed on either the "how to do it" or the policy on this, will someone please dupe this to that bug?

take care,
lee

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 66860

Comment 12

5 years ago
Thanks Lee!
You need to log in before you can comment on or make changes to this bug.