Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
5 years ago
2 years ago

People

(Reporter: lcamacho, Unassigned)

Tracking

({regression})

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20120810030512

Steps to reproduce:

Go to this adress http://cnettv.cnet.com/dell-xps-15-hands/9742-1_53-50129172.html and wait for the video to play.


Actual results:

The video never show, in fact the video player never shows.


Expected results:

The video should play.

The firebug console show me this error:

TypeError: N.getNext(...) is null
...mousemove:this.bound.check,mouseup:this.bound.cancel});this.document.addEvent(th...

in http://asset0.cbsistatic.com/cnwk.1d/html/rb/js/tron/cnettv/cnettv.tron.frontdoor.compressed.js line 4

Comment 1

5 years ago
Confirmed in OS X 10.6 nightly. This page works in 16.0a2, so a regression window would be nice.
Status: UNCONFIRMED → NEW
status-firefox16: --- → unaffected
status-firefox17: --- → affected
tracking-firefox17: --- → ?
Ever confirmed: true
Keywords: regression, regressionwindow-wanted
OS: Linux → All
Hardware: x86 → All
Last good nightly: 2012-08-04
First bad nightly: 2012-08-05

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=20fc34efd733&tochange=9453cf029b72
Keywords: regressionwindow-wanted

Comment 3

5 years ago
Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/aa100b9efcca
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120803104127
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/87e7abe891a9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120803113827
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=aa100b9efcca&tochange=87e7abe891a9

suspected: Bug 772733
Assignee: nobody → general
Blocks: 772733
Component: Untriaged → JavaScript Engine
Product: Firefox → Core

Comment 4

5 years ago
It does seem to be using a .contains() method on String a few times. I don't know how worked originally. Browser detection gone wrong?
(Reporter)

Comment 5

5 years ago
I just test Firefox 14 with the user agent of Nightly and the video works, is not the user agent.

Comment 6

5 years ago
String.contains defines in http://asset3.cbsistatic.com/cnwk.1d/html/rb/js/tron/oreo.moo.rb.combined.js

So , does MooTools conflict with Bug 772733?

Comment 7

5 years ago
It looks like MooTool's contains() is incompatible with ES6's.

Comment 8

5 years ago
MooTools' bug submitted: https://github.com/mootools/mootools-core/issues/2402

Updated

5 years ago
Assignee: general → english-us
Component: JavaScript Engine → English US
Product: Core → Tech Evangelism
Version: 17 Branch → unspecified
tracking-firefox17: ? → +

Updated

5 years ago
Duplicate of this bug: 784280

Comment 10

5 years ago
I should note only Mootools 1.2 is afflicted. Mootools >= 1.3 is fine.

Updated

5 years ago
status-firefox18: --- → affected
tracking-firefox18: --- → ?
tracking-firefox18: ? → +

Updated

5 years ago
Blocks: 789036

Updated

5 years ago
No longer blocks: 772733

Updated

5 years ago
Duplicate of this bug: 789093

Updated

5 years ago
Duplicate of this bug: 789316
Well, Cnet changed their website. Now it seems to be fully compatible with Firefox 18. We'll see if it stays that way.

Comment 14

5 years ago
Great!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Alright. So that was a one time thing, and they are now back to the old layout. This means, of course, it no longer works. This is getting quite annoying.

Updated

5 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

5 years ago
Blocks: 793781

Updated

5 years ago
No longer blocks: 793781
tracking-firefox19: --- → ?
I started tracking firefox-19, as the problem is still there.
(In reply to infinitefirefox from comment #16)
> I started tracking firefox-19, as the problem is still there.

WFM.. latest hourly cset: https://hg.mozilla.org/mozilla-central/rev/ec10630b1a54
win32 m-c trunk on win7 x64

Updated

5 years ago
status-firefox16: unaffected → ---
status-firefox17: affected → ---
status-firefox18: affected → ---
status-firefox19: --- → affected

Updated

5 years ago
status-firefox18: --- → affected
tracking-firefox17: + → ---

Comment 18

5 years ago
Indeed, they're still using MooTools 1.2 AFAICT.
Is anybody still able to reproduce this? I can't in the latest 10/16 nightly using the URL in comment 0.
tracking-firefox19: ? → +
Videos do indeed work. However the slideshow is still broken. Since all slideshow related issues seem to be forwarding here, I don't think we can resolve the bug. Although, since the two issues seem to not be related anymore, perhaps we should close this one and open back up the others.
Alright. I believe this issue is resolved. I'm going to reopen my Slideshow issue though.

Updated

5 years ago
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Not tracking it for release as the issue no longer happens based on comment 20
tracking-firefox18: + → -
tracking-firefox19: + → -
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.