Note: There are a few cases of duplicates in user autocompletion which are being worked on.

In-product MooTools 1.2.x fix

RESOLVED FIXED

Status

()

Core
JavaScript Engine
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: akeybl, Assigned: Benjamin)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox17+ fixed, firefox18+ wontfix, firefox19+ wontfix, firefox20 affected)

Details

(Whiteboard: [js:t])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Perform the necessary disable of bug 772733 until the effect of TE outreach in bug 789036 rolls out across the web.

+++ This bug was initially created as a clone of Bug #789036 +++

This is a meta bug for breakage caused by bug 772733's addition of String.prototype.contains. MooTools defines a incompatible version of String.prototype.contains. Versions of MooTools greater than 1.2 override the builtin implementation, but 1.2.x assumes it is a compatible implementation. Upgrading to any later version of MooTools fixes the problem.

A MooTools bug has been filed:
https://github.com/mootools/mootools-core/issues/2402

Comment 1

5 years ago
Benjamin: I haven't really been following this MooTools stuff; would you like to land the disabling patch?  I can do it if you're busy.

Comment 2

5 years ago
n/m, I might as well do it.
(Assignee)

Comment 3

5 years ago
I can do it; it's trivial, though, so I had put it on backburner.

Comment 4

5 years ago
It wasn't clear in bug 789036: what version(s) should 'contains' be disabled on?
(Assignee)

Comment 5

5 years ago
17

Comment 6

5 years ago
If there are any FF chrome JS uses, were you planning to keep a prefixed 'mozContains' or something else?
(Assignee)

Comment 7

5 years ago
I don't think there are any in 17 (running Try now to find out).
(Assignee)

Updated

5 years ago
No longer depends on: 781796, 786584, 788483, 790462, 791980, 784280, 789093

Updated

5 years ago
Assignee: luke → benjamin
FYI - we should really do this before it hits Beta, which means landing this week. So please let me know if something comes up and you're not going to be able to get it in that time.
(Assignee)

Comment 9

5 years ago
Created attachment 667187 [details] [diff] [review]
disable
Attachment #667187 - Flags: review?(luke)
Attachment #667187 - Flags: approval-mozilla-aurora?

Comment 10

5 years ago
Comment on attachment 667187 [details] [diff] [review]
disable

Thanks!  (I wish the wild wild webz were more appreciative of your hard work :)
Attachment #667187 - Flags: review?(luke) → review+
(Reporter)

Comment 11

5 years ago
Comment on attachment 667187 [details] [diff] [review]
disable

Thanks for pulling this together - there's a good chance we'll also disable again for FF18 (and up) unless a TE effort works out.
Attachment #667187 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 12

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/086db97198a8
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Status: RESOLVED → REOPENED
status-firefox17: --- → fixed
status-firefox18: --- → affected
Resolution: FIXED → ---

Updated

5 years ago
Status: REOPENED → NEW
Whiteboard: [js:t]
(Reporter)

Comment 13

5 years ago
Let's land this fix on central/aurora. There's little chance that 6 weeks will change the situation here, since many sites won't have upgraded. I'd rather not revisit each release.
(Reporter)

Updated

5 years ago
status-firefox19: --- → affected
tracking-firefox19: --- → +
(Assignee)

Comment 14

5 years ago
It's not quite that easy, since usage of .contains() in the browser has been growing like weeds.
(Reporter)

Comment 15

5 years ago
Spoke with Ben, we'll try to do as much outreach as possible, and be on the lookout for web regressions with support here.
status-firefox18: affected → wontfix
status-firefox19: affected → wontfix

Comment 16

5 years ago
Firefox 20 added to the list
status-firefox20: --- → affected
(Assignee)

Comment 17

4 years ago
Don't need this bug anymore.
Status: NEW → RESOLVED
Last Resolved: 5 years ago4 years ago
Resolution: --- → FIXED
Can we also remove this from the release notes?
https://www.mozilla.org/en-US/firefox/21.0a2/auroranotes/
You need to log in before you can comment on or make changes to this bug.