The default bug view has changed. See this FAQ.

add carrier field and ContactField interface to Contacts API

RESOLVED FIXED in mozilla17

Status

()

Core
DOM: Device Interfaces
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: gal, Assigned: gwagner)

Tracking

(Blocks: 1 bug)

Trunk
mozilla17
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
The product teams agreed that they need a carrier field for each phone number of a contact. Jonas has signed off on the change. Gregor will try to finish it by EOD August 13 along with a few other minor changes since this involves a schema change.
(Reporter)

Updated

5 years ago
Assignee: nobody → anygregor
(Assignee)

Updated

5 years ago
blocking-basecamp: --- → ?
(Assignee)

Comment 1

5 years ago
I will also add multivalue interface ContactField in this bug.
Summary: add carrier field to Contacts API → add carrier field and ContactField interface to Contacts API
(Assignee)

Updated

5 years ago
Blocks: 746443
(Assignee)

Comment 2

5 years ago
Created attachment 651211 [details] [diff] [review]
IDL
Whiteboard: [blocked-on-input Chris Lee]
(In reply to Andreas Gal :gal from comment #0)
> The product teams agreed that they need a carrier field for each phone
> number of a contact. Jonas has signed off on the change. Gregor will try to
> finish it by EOD August 13 along with a few other minor changes since this
> involves a schema change.

Where did that discussion happen? Any link?
I wonder how that would be used? Would that be pre-filled by the phone or filed by the user?
OS: Mac OS X → All
Hardware: x86 → All
All the discussion was held at: https://groups.google.com/forum/?fromgroups#!topic/mozilla.dev.gaia/T-dsKQt3zYs[1-25]
(Assignee)

Comment 5

5 years ago
Created attachment 651522 [details] [diff] [review]
Impl patch
(Assignee)

Comment 6

5 years ago
Created attachment 651524 [details] [diff] [review]
IDL
Attachment #651211 - Attachment is obsolete: true
Attachment #651524 - Flags: review?(jonas)
(Assignee)

Updated

5 years ago
Attachment #651522 - Flags: review?(fabrice)
(Reporter)

Comment 7

5 years ago
Review ping. This is urgently needed. Other work is blocked on it.

Updated

5 years ago
blocking-basecamp: ? → +
Whiteboard: [blocked-on-input Chris Lee]
Comment on attachment 651522 [details] [diff] [review]
Impl patch

Review of attachment 651522 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/contacts/fallback/ContactDB.jsm
@@ +127,5 @@
>          // Create new searchable indexes.
>          objectStore.createIndex("email", "search.email", { unique: false, multiEntry: true });
> +      } else if (currVersion == 3) {
> +        debug("upgrade 3");
> + 

nit: whitespace

@@ +216,5 @@
>  
>                // Chop off the first characters
> +              let number = aContact.properties[field][i].value;
> +              if (number) {
> +                for(let i = 0; i < number.length; i++) {

nit: for (...)
Attachment #651522 - Flags: review?(fabrice) → review+
(Reporter)

Comment 9

5 years ago
Comment on attachment 651524 [details] [diff] [review]
IDL

stealing, looks good to me, we can always tweak after landing
Attachment #651524 - Flags: review?(jonas) → review+
Comment on attachment 651524 [details] [diff] [review]
IDL

Review of attachment 651524 [details] [diff] [review]:
-----------------------------------------------------------------

r+=me if you change the type to be just a string. Otherwise I'd like to hear why we think there are more cases that will be dealing with importing/exporting vcard data than that will be displaying the type in UI. Anytime we are displaying the type in UI we need a single string. The array is only needed when importing/exporting to vcard.

r=me on adding the carrier field either way.
Attachment #651524 - Flags: review-
(Assignee)

Comment 11

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/82dba0cf6958
https://hg.mozilla.org/integration/mozilla-inbound/rev/ab0c6dd14478
(Assignee)

Comment 12

5 years ago
Forgot the review comments:
https://hg.mozilla.org/integration/mozilla-inbound/rev/01a3cbde459c
(Assignee)

Updated

5 years ago
Duplicate of this bug: 772095
https://hg.mozilla.org/mozilla-central/rev/ab0c6dd14478
https://hg.mozilla.org/mozilla-central/rev/82dba0cf6958
https://hg.mozilla.org/mozilla-central/rev/01a3cbde459c
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla17
(Assignee)

Updated

5 years ago
Depends on: 784075
(Assignee)

Updated

5 years ago
Depends on: 784099
You need to log in before you can comment on or make changes to this bug.