Last Comment Bug 782272 - Intermittent test_history_tracker.js | test failed (with xpcshell return code: 0) | head.js| TypeError: tracker._lazySave is null
: Intermittent test_history_tracker.js | test failed (with xpcshell return code...
Status: RESOLVED FIXED
: intermittent-failure
Product: Core
Classification: Components
Component: Web Services (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: mozilla18
Assigned To: :Benjamin Peterson
:
Mentors:
Depends on: 722956
Blocks: 438871
  Show dependency treegraph
 
Reported: 2012-08-13 07:36 PDT by Ed Morley [:emorley]
Modified: 2012-11-25 19:31 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
check for null (752 bytes, patch)
2012-09-23 11:36 PDT, :Benjamin Peterson
gps: review+
Details | Diff | Splinter Review

Description Ed Morley [:emorley] 2012-08-13 07:36:09 PDT
Rev3 WINNT 6.1 mozilla-inbound debug test xpcshell on 2012-08-12 23:12:19 PDT for push 9e0799cf1096

slave: talos-r3-w7-059

https://tbpl.mozilla.org/php/getParsedLog.php?id=14333822&tree=Mozilla-Inbound

{
TEST-INFO | c:/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_history_tracker.js | Starting cleanup
Clean up.

TEST-UNEXPECTED-FAIL | c:\talos-slave\test\build\xpcshell\head.js | TypeError: tracker._lazySave is null - See following stack:
JS frame :: c:\talos-slave\test\build\xpcshell\head.js :: do_throw :: line 451
JS frame :: c:\talos-slave\test\build\xpcshell\head.js :: _run_next_test :: line 899
JS frame :: c:\talos-slave\test\build\xpcshell\head.js :: <TOP_LEVEL> :: line 418
}
Comment 1 Treeherder Robot 2012-09-23 11:27:42 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=15459716&tree=Firefox
Rev3 Fedora 12 mozilla-central opt test xpcshell on 2012-09-23 10:25:57
slave: talos-r3-fed-036

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/services/sync/tests/unit/test_history_tracker.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/head.js | TypeError: tracker._lazySave is null - See following stack:
Comment 2 :Benjamin Peterson 2012-09-23 11:36:33 PDT
Created attachment 663835 [details] [diff] [review]
check for null
Comment 3 Philipp von Weitershausen [:philikon] 2012-09-23 11:40:48 PDT
Comment on attachment 663835 [details] [diff] [review]
check for null

403 gps :)
Comment 4 :Benjamin Peterson 2012-09-23 11:53:17 PDT
(In reply to Philipp von Weitershausen [:philikon] from comment #3)
> Comment on attachment 663835 [details] [diff] [review]
> check for null
> 
> 403 gps :)

You mean 303? :)
Comment 5 Philipp von Weitershausen [:philikon] 2012-09-23 12:01:50 PDT
(In reply to Benjamin Peterson [:benjamin] from comment #4)
> (In reply to Philipp von Weitershausen [:philikon] from comment #3)
> > Comment on attachment 663835 [details] [diff] [review]
> > check for null
> > 
> > 403 gps :)
> 
> You mean 303? :)

I meant 302... off-by-one error in the left hand :/
Comment 6 Gregory Szorc [:gps] 2012-09-24 13:59:14 PDT
Comment on attachment 663835 [details] [diff] [review]
check for null

Review of attachment 663835 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good except for some improper English in the commit message. s/its/it's/ and s/their/there/.

There's a few other tests also not conditionally checking for _lazySave. I guess we're just lucky and don't have errors elsewhere. If you would be so kind to do a follow-up patch to address these other instances, it would be appreciated. I may even favor a "destructor" API on tracker. If you don't want to do it, no worries.
Comment 7 :Benjamin Peterson 2012-09-24 14:04:13 PDT
(In reply to Gregory Szorc [:gps] from comment #6)
> Comment on attachment 663835 [details] [diff] [review]
> check for null
> 
> Review of attachment 663835 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Looks good except for some improper English in the commit message.
> s/its/it's/ and s/their/there/.
> 
> There's a few other tests also not conditionally checking for _lazySave. I
> guess we're just lucky and don't have errors elsewhere. If you would be so
> kind to do a follow-up patch to address these other instances, it would be
> appreciated. I may even favor a "destructor" API on tracker. If you don't
> want to do it, no worries.

I looked a most of those. I think they're mostly okay, though, because they call saveChangedIDs immediately beforehand. saveChangedIDs actually creates the timer.
Comment 9 Ed Morley [:emorley] 2012-09-25 06:20:21 PDT
https://hg.mozilla.org/mozilla-central/rev/426fd9c73834

Note You need to log in before you can comment on or make changes to this bug.