Last Comment Bug 782275 - Disable devicestorage tests on Android
: Disable devicestorage tests on Android
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: mozilla17
Assigned To: Ed Morley [:emorley]
:
Mentors:
Depends on: 781789
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-13 07:49 PDT by Ed Morley [:emorley]
Modified: 2012-08-14 06:02 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Disable on Android (1.57 KB, patch)
2012-08-13 09:42 PDT, Ed Morley [:emorley]
dougt: review-
Details | Diff | Review
Disable on Android v2 (3.08 KB, patch)
2012-08-13 10:34 PDT, Ed Morley [:emorley]
dougt: review+
Details | Diff | Review

Description Ed Morley [:emorley] 2012-08-13 07:49:54 PDT
Broken out from bug 781789:

 (In reply to Doug Turner (:dougt) from bug 781789 comment #6)
> we should really disable all devicestorage tests on android.
Comment 1 Ed Morley [:emorley] 2012-08-13 07:53:04 PDT
Doug, did you mean dom/devicestorage/test/* or dom/devicestorage/* (and thus the ipc directory as well)?
Comment 2 Doug Turner (:dougt) 2012-08-13 08:53:55 PDT
sorry ed - yes, disable the tests in dom/devicestorage/*
Comment 3 Ed Morley [:emorley] 2012-08-13 09:42:40 PDT
Created attachment 651426 [details] [diff] [review]
Disable on Android
Comment 4 Doug Turner (:dougt) 2012-08-13 10:21:27 PDT
Comment on attachment 651426 [details] [diff] [review]
Disable on Android

I think... you can also remove these lines from that file:


176  "dom/devicestorage/ipc/test_ipc.html": "",
177  "dom/devicestorage/test/test_basic.html": "",
178  "dom/devicestorage/test/test_dotdot.html": "",
179  "dom/devicestorage/test/test_enumerate.html": "",
180  "dom/devicestorage/test/test_enumerateMultipleContinue.html": "",
181  "dom/devicestorage/test/test_enumerateOptions.html": "",
182  "dom/devicestorage/test/test_lastModificationFilter.html": "",
183  "dom/devicestorage/test/test_overwrite.html": "",
184  "dom/devicestorage/test/test_sanity.html": "",
Comment 5 Ed Morley [:emorley] 2012-08-13 10:34:41 PDT
Created attachment 651455 [details] [diff] [review]
Disable on Android v2

Ah yes they can be taken out too.

I hadn't looked that far down in the file since the listing are supposed to be alphabetical, but those entries date from before devicestorage moved locations in the tree.
Comment 6 Ed Morley [:emorley] 2012-08-13 10:45:17 PDT
Thanks :-)

https://hg.mozilla.org/integration/mozilla-inbound/rev/cdb3c9eb8070
Comment 7 Ed Morley [:emorley] 2012-08-14 06:02:09 PDT
https://hg.mozilla.org/mozilla-central/rev/cdb3c9eb8070

Note You need to log in before you can comment on or make changes to this bug.