Closed Bug 782348 Opened 10 years ago Closed 10 years ago

Reader Mode: Add byline fetching support to Readability.js

Categories

(Firefox for Android Graveyard :: Reader View, defect)

All
Android
defect
Not set
normal

Tracking

(firefox16 verified, firefox17 verified, firefox18 verified)

VERIFIED FIXED
Firefox 17
Tracking Status
firefox16 --- verified
firefox17 --- verified
firefox18 --- verified

People

(Reporter: lucasr, Assigned: lucasr)

References

Details

Attachments

(1 file)

Fetch author info to show in reader mode. We should probably fetch it when the page follows the hNews format (http://microformats.org/wiki/hnews) or uses classes like "author", "byline", etc.
Blocks: reader
Attachment #652102 - Flags: review?(bnicholson)
Assignee: nobody → lucasr.at.mozilla
Comment on attachment 652102 [details] [diff] [review]
Fetch byline info from articles to show on Reader

+    this._creditsElement.innerHTML = article.byline;

Where does creditsElement come from?


I wonder if it's possible for the byline to appear twice (in the parsed article and new credits element). Should we remove the byline node after extracting the author from it?
Comment on attachment 652102 [details] [diff] [review]
Fetch byline info from articles to show on Reader

Review of attachment 652102 [details] [diff] [review]:
-----------------------------------------------------------------

(In reply to Brian Nicholson (:bnicholson) from comment #2)
> Where does creditsElement come from?

Looks like it came from bug 766948.
Attachment #652102 - Flags: review?(bnicholson) → review+
https://hg.mozilla.org/mozilla-central/rev/fedc45481456
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 17
Comment on attachment 652102 [details] [diff] [review]
Fetch byline info from articles to show on Reader

[Approval Request Comment]
User impact if declined: Reader design shows author/date information whenever this information is available in the page.
Testing completed (on m-c, etc.): Landed on m-c, no regressions.
Risk to taking this patch (and alternatives if risky): Very low, worst case is to now show author/date.
String or UUID changes made by this patch: None.
Attachment #652102 - Flags: approval-mozilla-aurora?
Attachment #652102 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
This issue seems to be fixed on all branches. Closing bug as verified fixed.

--
Firefox 16.0b5 (2012-09-26)
Device: Galaxy Note
OS: Android 4.0.4
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.