Last Comment Bug 782793 - per-platform chat window icons
: per-platform chat window icons
Status: RESOLVED FIXED
[Fx17]
:
Product: Firefox
Classification: Client Software
Component: SocialAPI (show other bugs)
: 17 Branch
: All All
: -- normal (vote)
: Firefox 18
Assigned To: Shane Caraveo (:mixedpuppy) [on leave 5/16-7/16]
:
Mentors:
Depends on:
Blocks: 783687
  Show dependency treegraph
 
Reported: 2012-08-14 14:36 PDT by Shane Caraveo (:mixedpuppy) [on leave 5/16-7/16]
Modified: 2012-09-25 11:40 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Mockup: Chat window on OSX and Windows in read and unread (289.85 KB, image/png)
2012-08-29 19:54 PDT, Jennifer Morrow [:Boriss] (UX)
no flags Details
Icons: OSX & Windows chat controls on default, hover, click states (13.46 KB, application/zip)
2012-08-29 19:55 PDT, Jennifer Morrow [:Boriss] (UX)
no flags Details
chat style.patch (28.80 KB, patch)
2012-08-31 14:09 PDT, Shane Caraveo (:mixedpuppy) [on leave 5/16-7/16]
jaws: review-
Details | Diff | Review
chat style.patch (19.60 KB, patch)
2012-09-04 14:45 PDT, Shane Caraveo (:mixedpuppy) [on leave 5/16-7/16]
felipc: review+
dao+bmo: review-
Details | Diff | Review
Landed patch (21.29 KB, patch)
2012-09-10 08:27 PDT, :Felipe Gomes (needinfo me!)
gavin.sharp: approval‑mozilla‑aurora+
Details | Diff | Review

Description Shane Caraveo (:mixedpuppy) [on leave 5/16-7/16] 2012-08-14 14:36:20 PDT
we need a minimize/maximize icon, and a close icon for the chat window.  Right now we're just grabbing some preexisting icons from the themes.
Comment 1 Jennifer Morrow [:Boriss] (UX) 2012-08-29 19:54:20 PDT
Created attachment 656729 [details]
Mockup: Chat window on OSX and Windows in read and unread

Attached are a mockup and the image files for chat window default colors on OSX and on Windows.  The first version won’t include the pop_out icon, but I’m attaching it to this bug for future use.  Clicking on the titlebar collapses the window.
Comment 2 Jennifer Morrow [:Boriss] (UX) 2012-08-29 19:55:34 PDT
Created attachment 656731 [details]
Icons: OSX & Windows chat controls on default, hover, click states
Comment 3 Shane Caraveo (:mixedpuppy) [on leave 5/16-7/16] 2012-08-31 13:04:48 PDT
taking this to create the patch
Comment 4 Shane Caraveo (:mixedpuppy) [on leave 5/16-7/16] 2012-08-31 14:09:48 PDT
Created attachment 657442 [details] [diff] [review]
chat style.patch

adds close icons and colors for all platforms.  needs verification on linux.
Comment 5 Jared Wein [:jaws] (please needinfo? me) 2012-09-02 07:58:45 PDT
Comment on attachment 657442 [details] [diff] [review]
chat style.patch

Review of attachment 657442 [details] [diff] [review]:
-----------------------------------------------------------------

Please make the chat_close, chat_close_onclick, and chat_close_onhover all part of one image sprite. Using CSS to switch the current image like this when they reside in different files can show a flicker during the transition.

::: browser/themes/gnomestripe/browser.css
@@ +2748,5 @@
>    font-weight: bold;
>    color: -moz-dialogtext;
>  }
>  
>  .chat-titlebar {

Please add |cursor: pointer;| for the titlebar now that it will toggle the minimized/restored state and help with discoverability.

@@ +2763,5 @@
>  .chat-titlebar[minimized="true"] {
>    border-bottom: none;
>  }
>  
> +.chat-titlebar[selected="true"] {

.chat-titlebar[selected] since we never have a non-"true" value for the attribute.
Comment 6 Shane Caraveo (:mixedpuppy) [on leave 5/16-7/16] 2012-09-04 14:45:21 PDT
Created attachment 658243 [details] [diff] [review]
chat style.patch
Comment 7 Dão Gottwald [:dao] 2012-09-07 04:21:40 PDT
Comment on attachment 658243 [details] [diff] [review]
chat style.patch

>--- a/browser/themes/winstripe/jar.mn
>+++ b/browser/themes/winstripe/jar.mn
>@@ -99,16 +99,17 @@ browser.jar:
>         skin/classic/browser/preferences/Options-sync.png            (preferences/Options-sync.png)
> #endif
>         skin/classic/browser/preferences/saveFile.png                (preferences/saveFile.png)
> *       skin/classic/browser/preferences/preferences.css             (preferences/preferences.css)
>         skin/classic/browser/preferences/in-content/preferences.css  (preferences/in-content/preferences.css)
>         skin/classic/browser/preferences/applications.css            (preferences/applications.css)
>         skin/classic/browser/preferences/aboutPermissions.css        (preferences/aboutPermissions.css)
>         skin/classic/browser/social/social.png                       (social/social.png)
>+        skin/classic/browser/social/chat_close.png                   (social/chat_close.png)
>         skin/classic/browser/tabbrowser/alltabs.png                  (tabbrowser/alltabs.png)
>         skin/classic/browser/tabbrowser/newtab.png                   (tabbrowser/newtab.png)
>         skin/classic/browser/tabbrowser/newtab-inverted.png          (tabbrowser/newtab-inverted.png)
>         skin/classic/browser/tabbrowser/connecting.png               (tabbrowser/connecting.png)
>         skin/classic/browser/tabbrowser/loading.png                  (tabbrowser/loading.png)
>         skin/classic/browser/tabbrowser/tab.png                      (tabbrowser/tab.png)
>         skin/classic/browser/tabbrowser/tab-arrow-left.png           (tabbrowser/tab-arrow-left.png)
>         skin/classic/browser/tabbrowser/tab-arrow-left-inverted.png  (tabbrowser/tab-arrow-left-inverted.png)

You forgot adding this to the aero section.
Comment 8 :Felipe Gomes (needinfo me!) 2012-09-07 04:25:47 PDT
yeah I noticed that before pushing and added it to the patch. Also changed the file name to chat-close.png (using the dash) to follow the convention

https://hg.mozilla.org/integration/mozilla-inbound/rev/d3c66f475f33
Comment 9 Shane Caraveo (:mixedpuppy) [on leave 5/16-7/16] 2012-09-07 09:28:52 PDT
Comment on attachment 658243 [details] [diff] [review]
chat style.patch

[Approval Request Comment]
status and flyout panel appearance needs to match the ux design.  the correct patch is in comment #8, which was modified to add aero styles
Comment 10 Shane Caraveo (:mixedpuppy) [on leave 5/16-7/16] 2012-09-07 09:30:32 PDT
(In reply to Shane Caraveo (:mixedpuppy) from comment #9)
> Comment on attachment 658243 [details] [diff] [review]
> chat style.patch
> 
> [Approval Request Comment]
> status and flyout panel appearance needs to match the ux design.  the
> correct patch is in comment #8, which was modified to add aero styles

make that, chat icons :(  but also correcting to match ux design
Comment 11 Lukas Blakk [:lsblakk] use ?needinfo 2012-09-07 16:05:45 PDT
Fwiw, usually the nomination for branch uplift comes after the patch has landed on trunk and ben resolved fixed (ideally, verified). Will come back to check on this at another time.
Comment 12 Ryan VanderMeulen [:RyanVM] 2012-09-07 16:52:05 PDT
https://hg.mozilla.org/mozilla-central/rev/d3c66f475f33
Comment 13 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-09-10 08:20:14 PDT
Can you attach the landed patch for approval, so that I don't have to a+ an r-ed patch?
Comment 14 :Felipe Gomes (needinfo me!) 2012-09-10 08:27:46 PDT
Created attachment 659724 [details] [diff] [review]
Landed patch
Comment 15 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-09-25 11:40:38 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/53f2c795e802

Note You need to log in before you can comment on or make changes to this bug.