Last Comment Bug 782876 - Remove unnecessary returns from media mochitest event handlers
: Remove unnecessary returns from media mochitest event handlers
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla17
Assigned To: Matthew Gregan [:kinetik]
:
Mentors:
Depends on: 770945
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-14 21:41 PDT by Matthew Gregan [:kinetik]
Modified: 2012-08-17 05:27 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v0 (19.42 KB, patch)
2012-08-14 21:42 PDT, Matthew Gregan [:kinetik]
cajbir.bugzilla: review+
Details | Diff | Review

Description Matthew Gregan [:kinetik] 2012-08-14 21:41:13 PDT
A bunch of our tests "return false" from the handler, but it's unnecessary since our events aren't bubbling (since bug 608630) or cancellable (since bug 770945).

Also removes a couple of tests for completed variables that are declared false and never set to true.

Deletes 70 lines.  Green locally, pushed to try: https://tbpl.mozilla.org/?tree=Try&rev=9b44c69194fc
Comment 1 Matthew Gregan [:kinetik] 2012-08-14 21:42:25 PDT
Created attachment 651995 [details] [diff] [review]
patch v0
Comment 2 Matthew Gregan [:kinetik] 2012-08-16 20:39:03 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/61c03f309b98
Comment 3 Ed Morley [:emorley] 2012-08-17 05:27:22 PDT
https://hg.mozilla.org/mozilla-central/rev/61c03f309b98

Note You need to log in before you can comment on or make changes to this bug.