BrowserNewTabPreloader.jsm and SafeBrowsing.jsm are referenced using the wrong URI

VERIFIED FIXED in Firefox 17

Status

()

Firefox
General
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: ojab, Assigned: glandium)

Tracking

Trunk
Firefox 18
x86_64
All
Points:
---

Firefox Tracking Flags

(firefox17 verified)

Details

(Whiteboard: [qa-])

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
I'm using Fx from mozilla-inbound and after Bug 753448 (exactly -r102295:a5b58ae99ac9) fixed 'New Tab' button opens new tab, but doesn't switch to it.

I should mention that I'm using firefox from objdir without actually installing it, so I have 'mk_add_options MOZ_OBJDIR=/home/ojab/opt' in mozconfig and running Fx with `~/opt/browser/dist/bin/firefox`.

I've found that there is two errors in 'Error Console':

Timestamp: 15.08.2012 11:50:04
Error: NS_ERROR_FILE_NOT_FOUND: Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIXPCComponents_Utils.import]
Source File: chrome://browser/content/browser.js
Line: 153

Timestamp: 15.08.2012 11:50:06
Error: NS_ERROR_FILE_NOT_FOUND: Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIXPCComponents_Utils.import]
Source File: chrome://browser/content/browser.js
Line: 146


which are "resource://gre/modules/BrowserNewTabPreloader.jsm" and "resource://gre/modules/SafeBrowsing.jsm", which are resides only in /home/ojab/opt/browser/dist/bin/modules/.

I've looked on PluralForm.jsm as an other example of file in resource://gre/modules/ and it resides in /home/ojab/opt/xulrunner/dist/bin/modules/PluralForm.jsm and /home/ojab/opt/browser/dist/bin/xulrunner/modules/PluralForm.jsm, so I've copied BrowserNewTabPreloader.jsm and SafeBrowsing.jsm to /home/ojab/opt/browser/dist/bin/xulrunner/modules and 'New Tab' button works as expected even after I've deleting this files again (looks like it's cached somewhere in profile or something like that).

As a side note: I've had an issue with session restore (Bug 779107) related to SafeBrowsing.jsm not found, but it as fixed somehow (most likely when I've run official Nightly build for the test) and I haven't found the source.

So I think that BrowserNewTabPreloader.jsm and SafeBrowsing.jsm should actually be built in xulrunner, not in browser.
(Assignee)

Comment 1

6 years ago
They should just be included with the right url.
Assignee: nobody → mh+mozilla
Status: UNCONFIRMED → NEW
Component: Build Config → General
Ever confirmed: true
OS: Linux → All
(Assignee)

Comment 2

6 years ago
Created attachment 657306 [details] [diff] [review]
browser.js includes SafeBrowsing.jsm and BrowserNewTabPreloader.jsm with the wrong url
(Assignee)

Updated

6 years ago
Blocks: 755724
(Assignee)

Updated

6 years ago
Attachment #657306 - Flags: review?(gavin.sharp)
(Assignee)

Updated

6 years ago
status-firefox17: --- → affected
Attachment #657306 - Flags: review?(gavin.sharp)
Attachment #657306 - Flags: review+
Attachment #657306 - Flags: approval-mozilla-aurora+
Summary: BrowserNewTabPreloader.jsm and SafeBrowsing.jsm should reside in xulrunner → BrowserNewTabPreloader.jsm and SafeBrowsing.jsm are referenced using the wrong URI
https://hg.mozilla.org/mozilla-central/rev/4c3fae3b9156
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 18
(Assignee)

Comment 5

6 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/8d3c569917d4
status-firefox17: affected → fixed
(Reporter)

Comment 6

6 years ago
Sorry for the late test, looks like it isn't fixed (or was fixed, but broken again, unfortunately doesn't follow hg log closely).
After clean Fx rebuild (Built from http://hg.mozilla.org/integration/mozilla-inbound/rev/65cf1362d58c) Ctrl-T opens New Tab, but doesn't switch to it. In error console there is:

Timestamp: 21.09.2012 19:18:22
Error: NS_ERROR_FILE_NOT_FOUND: Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIXPCComponents_Utils.import]
Source File: resource://gre/modules/XPCOMUtils.jsm
Line: 222

after first Ctrl-T and

Timestamp: 21.09.2012 19:18:23
Error: ReferenceError: gBrowserNewTabPreloader is not defined
Source File: chrome://browser/content/tabbrowser.xml
Line: 1394

after next Ctrl-Ts.

strace shows 
lstat("/home/ojab/opt/browser/dist/bin/xulrunner/modules/BrowserNewTabPreloader.jsm", 0x7fffb4444fa0) = -1 ENOENT (No such file or directory)
stat("/home/ojab/opt/browser/dist/bin/xulrunner/modules/BrowserNewTabPreloader.jsm", 0x7fc4d57ae7d8) = -1 ENOENT (No such file or directory)
lstat("/home/ojab/opt/browser/dist/bin/xulrunner/modules/BrowserNewTabPreloader.jsm", 0x7fc4d57ae7d8) = -1 ENOENT (No such file or directory)

and after copying or even moving BrowserNewTabPreloader.jsm to his location (from /home/ojab/opt/browser/dist/bin/modules/BrowserNewTabPreloader.jsm after Fx build) Ctrl-T works fine.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I'm sorry.
Created attachment 663426 [details] [diff] [review]
yet another patch
Attachment #663426 - Flags: review?(gavin.sharp)
Attachment #663426 - Flags: review?(gavin.sharp) → review+
https://hg.mozilla.org/mozilla-central/rev/243f94de7936
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
(Reporter)

Comment 12

6 years ago
Can I haz fix in mozilla-inbound tree?
As a side note, what is the purpose of fx-team tree? I can't google anything useful.
It's just another mozilla-central integration branch, like inbound. This'll make it to inbound eventually as the merges happen :)
ojab, can you please confirm this is fixed for you now?
Whiteboard: [qa-]
(Reporter)

Comment 15

6 years ago
Confirming, it's fixed.
Thanks ojab!
Status: RESOLVED → VERIFIED
status-firefox17: fixed → verified

Comment 17

6 years ago
We need to undo this change now that bug 778608 has landed.

Comment 18

6 years ago
(In reply to Jim Mathies [:jimm] from comment #17)
> We need to undo this change now that bug 778608 has landed.

(For safe browsing only, I'll file a follow up)
You need to log in before you can comment on or make changes to this bug.