HTML 5 Edge animation is not displayed correctly.

RESOLVED DUPLICATE of bug 747637

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 747637
5 years ago
5 years ago

People

(Reporter: sanmiguelga, Unassigned)

Tracking

14 Branch
x86_64
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713134347

Steps to reproduce:

We have a slideshow animation created with Adobe Edge preview 5, which worked just fine with the previous Mozilla's version.
see it here www.bhsalud.com



Actual results:

When we updated to the newest Mozilla's version 14.0.1, we found out that it doesn't display it correctly, while in all the other browsers it runs smoothly.


Expected results:

The animation should have been displayed well, as it was in the previous Mozilla's version and in all other browsers.
(Reporter)

Updated

5 years ago

Comment 1

5 years ago
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c61855cb4558&tochange=8b48e42774f6

And It works in Firefox15Beta , Aurora16.0a2 and Nightly17.0a1
Blocks: 734953
Component: Untriaged → Style System (CSS)
Depends on: 747637
OS: Windows 7 → All
Product: Firefox → Core
Don't forget to file a bug with Adobe Edge. Fundamentally that tool should no more generate something using skew() as it isn't standard (even if it is supported in Firefox and other browser).

In the general case, this isn't a skew function; and in the specific case, skewX() and skewY(), which are real skew functions, do the trick.
Dupe of bug 747637, I'm pretty sure (which has been backported to Aurora & Beta, which is why this works there, per comment 1.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 747637
(In reply to Jean-Yves Perrier [:teoli] from comment #2)
> Don't forget to file a bug with Adobe Edge. Fundamentally that tool should
> no more generate something using skew() as it isn't standard (even if it is
> supported in Firefox and other browser).

FWIW, we're apparently going to argue to add skew() in the standard, as noted in this chunk of bug 747637 comment 9:

> we intend to keep it [skew() support] indefinitely and get the spec
> updated to require it again.

So we probably don't need an Adobe Edge bug to be filed at this time.
Depends on: 803074
You need to log in before you can comment on or make changes to this bug.