Frequent crash while browsing: nsRootPresContext* in DOM is NULL

RESOLVED DUPLICATE of bug 782981

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 782981
6 years ago
6 years ago

People

(Reporter: sstangl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 652204 [details]
Backtrace.

Backtrace attached. The problem appears to be that nsObjectFrame::BeginSwapDocShells() queries objectFrame->PresContext()->GetRootPresContext(), and that value is NULL.

IonMonkey doesn't appear on the stack. Not sure whether we're causing the crash, but it doesn't happen on Nightly.

No particular steps to reproduce -- it crashes randomly when the browser is open for a long time. Visiting a page with embedded Flash may expedite the process.
What changeset is your build from?
(Reporter)

Comment 2

6 years ago
Reproduces even with javascript.options.ion.content disabled.

changeset:   104190:cfc77da79f9f
date:        Wed Aug 15 01:30:07 2012 +0200
Bug 777537 - Ensure validity of CompilerOutput without a dangling pointer. r=bhackett
(Reporter)

Updated

6 years ago
Assignee: general → nobody
No longer blocks: 745386
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Component: JavaScript Engine → Layout
Resolution: --- → DUPLICATE
Summary: IonMonkey: Frequent crash while browsing: nsRootPresContext* in DOM is NULL → Frequent crash while browsing: nsRootPresContext* in DOM is NULL
Duplicate of bug: 781272

Updated

6 years ago
Duplicate of bug: 782981
You need to log in before you can comment on or make changes to this bug.