Closed Bug 783270 Opened 8 years ago Closed 8 years ago

Box.com auth window suddenly loses focus after loading for the first time.

Categories

(Thunderbird :: FileLink, defect)

16 Branch
x86
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 768802

People

(Reporter: mconley, Unassigned)

Details

STR:

(Assumes no Box account is currently set up)

1) Do a cold start up of Thunderbird
2) Go to Preferences > Attachments > Outgoing, and choose to add a provider
3) Choose to add a Box account
4) Wait for the Box auth window to come up

What happens?

The auth window suddenly loses focus, and the modal Set up Filelink dialog suddenly pulls focus.

What's expected?

We should maintain focus on the auth window.
Ugh, so I just spent the last few hours chasing my tail.

Here are the dirty details:

1) The problem is caused by a pre-release version of the Adobe Flash plugin that I have on my Windows box.
2) The Box.com auth window loads an SWF on start-up to determine which version of Flash I have installed (via the SWFObject library)
3) Loading that SWF causes the 3pane window to re-focus in the pre-release version of Flash that I have.

This problem does not persist with the most recent release of Flash (11.3.300.271).

Marking as invalid.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → INVALID
For the record, the pre-release version of Flash I was using was Beta 2
11.4.400.252.
(In reply to Mike Conley (:mconley) from comment #1)
> 2) The Box.com auth window loads an SWF on start-up to determine which
> version of Flash I have installed (via the SWFObject library)

I didn't even notice there was Flash on this page. Would it help if I asked the Box folks if it could be removed?
(In reply to Brian King (Briks) [:kinger] from comment #3)
> (In reply to Mike Conley (:mconley) from comment #1)
> > 2) The Box.com auth window loads an SWF on start-up to determine which
> > version of Flash I have installed (via the SWFObject library)
> 
> I didn't even notice there was Flash on this page. Would it help if I asked
> the Box folks if it could be removed?

There isn't really any Flash on the page, but the SWFObject library is loaded, which embeds and then removes some Flash content on DOM loaded to determine the current Player version.

I've contacted Jeremy Glassenberg about it to see if it can be removed. Thanks!
The flash
Resolution: INVALID → DUPLICATE
Duplicate of bug: 768802
i submitted bug too early.
The flash bug is known and appeared by the new Flash protected mode for Firefox/Gecko.
You need to log in before you can comment on or make changes to this bug.